Problems compiling Tk::JPEG 
Author Message
 Problems compiling Tk::JPEG

I'm trying to compile and install Tk::JPEG an I get the following
problem:

 gcc -c
-I/net/zmers01a/disk1/spiffcc/tools/hpux-10.20/perl/5.6.1/lib/site_perl/5.6.1/PA-RISC2.0/Tk
-Ijpeg  -D_HPUX_SOURCE -L/lib/pa1.1 -DUINT32_MAX_BROKEN
-I/usr/local/include -O    -DVERSION=\"2.014\"  -DXS_VERSION=\"800.023\"
-fPIC
-I/net/zmers01a/disk1/spiffcc/tools/hpux-10.20/perl/5.6.1/lib/5.6.1/PA-RISC2.0/CORE
-Wall -Wno-implicit-int -Wno-comment -Wno-unused
-D__USE_FIXED_PROTOTYPES__ imgJPEG.c
Running Mkbootstrap for Tk::JPEG ()
        chmod 644 JPEG.bs
        rm -f blib/arch/auto/Tk/JPEG/JPEG.sl
        LD_RUN_PATH="" ld  -b -L/usr/local/lib JPEG.o  imgJPEG.o  -o
blib/arch/auto/Tk/JPEG/JPEG.sl jpeg/libjpeg.a
ld: DP relative code in file jpeg/libjpeg.a(jerror.o) - shared library
must be position
    independent.  Use +z or +Z to recompile.
*** Error exit code 1

Stop.

Does any one know how to fix this?

Thanks for your help

--
Walter Usyk - Tools Developer
Software Development Environment Tools (1P67)

ESN: 398-4603
Tel: (613) 768-4603



Sat, 05 Jun 2004 15:48:16 GMT  
 Problems compiling Tk::JPEG

Quote:
> I'm trying to compile and install Tk::JPEG an I get the following
> problem:

>  gcc -c
> -I/net/zmers01a/disk1/spiffcc/tools/hpux-10.20/perl/5.6.1/lib/site_perl/5.6.1/PA-RISC2.0/Tk
> -Ijpeg  -D_HPUX_SOURCE -L/lib/pa1.1 -DUINT32_MAX_BROKEN
> -I/usr/local/include -O    -DVERSION=\"2.014\"  -DXS_VERSION=\"800.023\"
> -fPIC
> -I/net/zmers01a/disk1/spiffcc/tools/hpux-10.20/perl/5.6.1/lib/5.6.1/PA-RISC2.0/CORE
> -Wall -Wno-implicit-int -Wno-comment -Wno-unused
> -D__USE_FIXED_PROTOTYPES__ imgJPEG.c
> Running Mkbootstrap for Tk::JPEG ()
>         chmod 644 JPEG.bs
>         rm -f blib/arch/auto/Tk/JPEG/JPEG.sl
>         LD_RUN_PATH="" ld  -b -L/usr/local/lib JPEG.o  imgJPEG.o  -o
> blib/arch/auto/Tk/JPEG/JPEG.sl jpeg/libjpeg.a
> ld: DP relative code in file jpeg/libjpeg.a(jerror.o) - shared library
> must be position
>     independent.  Use +z or +Z to recompile.
> *** Error exit code 1

> Stop.

> Does any one know how to fix this?

Does it help if you change in jpeg/Makefile.PL the line

  system("./configure");

to

  system("./configure --enable-shared");

?

Regards,
        Slaven

--

    tkrevdiff - graphical display of diffs between revisions (RCS or CVS)
    http://ptktools.sourceforge.net/#tkrevdiff



Sat, 05 Jun 2004 22:51:21 GMT  
 Problems compiling Tk::JPEG
Slaven,

Thank you. That did the trick.

Walter



Sat, 05 Jun 2004 23:32:45 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Problems compiling Tk::JPEG

2. problem with tk or tk:jpeg memory usage

3. Tk::PNG and Tk::JPeg module Problem

4. problem with tk or tk:jpeg memory usage

5. Free Pizza for Win32 Tk::JPEG compiled AS or GSAR

6. Free Pizza for Win32 Tk::JPEG compiled AS or GSAR

7. Tk::JPEG install problem

8. Tk804.024 Tk::JPEG-2.014 (perl 5.8.0) problems

9. Tk::Jpeg make problem

10. Solution found - Perl Module Tk::JPEG is not compatible with Tk

11. Help Tk::Jpeg and Tk 800.023

12. Hard-coded Solaris pathname in Tk::JPEG

 

 
Powered by phpBB® Forum Software