Apache/ModPerl Question 
Author Message
 Apache/ModPerl Question

        I have 2 CGI scripts which work correctly under CGI.  I set them
up to use ModPerl (the ::Registry module) and they work fine (including
much faster :-)   The Problem is that I also output a "Content-type:..."
HTTP header at the top of each page, and it DISPLAYS (as if a header has
already been sent to the browser)  This would not be a problem, except that
some of my pages use frames and to  remove the frames, I include a
:Window-target=_top clause to some of my headers (which just display now and
are otherwise ignored).  Is there any way to cause the server to NOT send
a header to the browser for you so that the browser will be expecting one
(as is the case in normal CGI?)  I have tried both using and not using
CGI.pm.

Thanks in advance for any help!!!!!!!!!!!

Jim Turner



Fri, 29 Sep 2000 03:00:00 GMT  
 Apache/ModPerl Question

Quote:

>         I have 2 CGI scripts which work correctly under CGI.  I set them
> up to use ModPerl (the ::Registry module) and they work fine (including
> much faster :-)   The Problem is that I also output a "Content-type:..."
> HTTP header at the top of each page, and it DISPLAYS (as if a header has
> already been sent to the browser)  This would not be a problem, except that
> some of my pages use frames and to  remove the frames, I include a
> :Window-target=_top clause to some of my headers (which just display now and
> are otherwise ignored).  Is there any way to cause the server to NOT send
> a header to the browser for you so that the browser will be expecting one
> (as is the case in normal CGI?)  I have tried both using and not using
> CGI.pm.

PerlSendHeader Off.

Place this directive in your httpd.conf, in the Location/Directory where
modperl
is configured.

Reinhard



Thu, 05 Oct 2000 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Apache/ModPerl Question

2. Apache&Modperl - Footers/Headers

3. Apache::DBI and modperl help!!!!!!!!!!!

4. apache+modperl slower

5. Modperl, Apache, DSO and Solaris/Sparc

6. Several questions about ModPerl

7. modperl question

8. Perl and Apache question. (A newbie question)

9. problem installing modperl!

10. sybperl+modperl on Solaris 2.6

11. undefined symbol-Problems with modperl

 

 
Powered by phpBB® Forum Software