Problem running perlmenu demo 
Author Message
 Problem running perlmenu demo

I've just installed PerlMenu v4.0 on Solaris 2.6 (using method 1 to get
around my getcap problem.)  When I run the demo, it displays ok but
every button pressed brings up this message:
  ->Use of uninitialized value at perlmenu.pm line 1546

Refreshing the screen gets rid of the message and the menu does display
the sub-menu or item selected.  A couple of the sub-menus will give me
the same error message except the complaint is with line 1495.

Here's line 1546:
  if (length($collect) > length($magic_seq[$i])){

And line 1495:
  &move($last_arrow_line,$left_margin+$last_arrow_col*($column_width));

Have I done something wrong in the install?

Thanks in advance!

Sent via Deja.com http://www.*-*-*.com/
Before you buy.



Sun, 23 Jun 2002 03:00:00 GMT  
 Problem running perlmenu demo

Quote:

> I've just installed PerlMenu v4.0 on Solaris 2.6 (using method 1 to
get
> around my getcap problem.)  When I run the demo, it displays ok but
> every button pressed brings up this message:
>   ->Use of uninitialized value at perlmenu.pm line 1546

.
.
.

I found out my problem.  I had put -w on the demo program.  Doh!

Sent via Deja.com http://www.deja.com/
Before you buy.



Sun, 30 Jun 2002 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Problem running demo/widget.

2. Win95 perlTk FileSelect demo does not run

3. Win95 perlTk FileSelect demo does not run

4. color_editor demo doesn't run

5. newbie trying to run demos

6. Problem with Curses/perlmenu

7. Problem with widget demo

8. Problem with ProgressBar Widget Demo

9. Problems with menu.pl under widget demo

10. Wanted: perlmenu uses

11. perlmenu and screen

12. Question on perlmenu ... HELP

 

 
Powered by phpBB® Forum Software