MAKE Error installing Libnet+POP3Client with ActivePerl on NT4 
Author Message
 MAKE Error installing Libnet+POP3Client with ActivePerl on NT4



Quote:
> I am having problems installing GBarrs Libnet package and Sean Dowds
> POP3Client.

> using ActivePerl on NT4. Both end up with error same error after running
> perl Makefile.PL and then trying to run 'make' on the resulting makefile.

> I get following error (line numbers  are different for the POP3Client but
> otherwise all else is same).
> ==========
>      make: makefile: line 703:  Error -- Expecting macro or rule defn,
found
> neither

Hi,
    Installing modules with ActivePerl is easiest using the ppm
utility - browsing http://www.*-*-*.com/
shows that the libnet package is there, but the POP3Client is
only available in the 5.005 series. If you are going to build the
packages yourself, get Microsoft's 'nmake' make program from
ftp://ftp.microsoft.com/softlib/MSLFILES/nmake15.exe and use
that, rather than the 'make' program like that from the cygwin
tools.

best regards,
randy kobes



Mon, 14 Oct 2002 03:00:00 GMT  
 MAKE Error installing Libnet+POP3Client with ActivePerl on NT4
Hi,

I was wondering if anytone can help ...

I am having problems installing GBarrs Libnet package and Sean Dowds
POP3Client.

using ActivePerl on NT4. Both end up with error same error after running
perl Makefile.PL and then trying to run 'make' on the resulting makefile.

I get following error (line numbers  are different for the POP3Client but
otherwise all else is same).

==========
     make: makefile: line 703:  Error -- Expecting macro or rule defn, found
neither

Dunno if you can help at all! It falls over on last bit of makefile. Here is
the extract...

pm_to_blib: $(TO_INST_PM)

        "-I$(PERL_ARCHLIB)" "-I$(PERL_LIB)" -MExtUtils::Install \
        -e "pm_to_blib(qw[ <<pmfiles.dat ],'$(INST_LIB)\auto')"

$(PM_TO_BLIB)
<<

# --- MakeMaker selfdocument section:

# --- MakeMaker postamble section:

# End.

=============
mant Thanks & Regards



Tue, 15 Oct 2002 03:00:00 GMT  
 MAKE Error installing Libnet+POP3Client with ActivePerl on NT4

Quote:
>I am having problems installing GBarrs Libnet package and Sean Dowds
>POP3Client.
>using ActivePerl on NT4.

ppm install libnet
ppm install POP3Client.

is what you want.  Using ppm on windows machines is much easier than
running nmake.

Rob
RICHLY TRAVEL CENTRE Next to the Train Station! - Bangkok
Tours Tickets Trekking for Thailand
http://richlybangkok.com/



Tue, 15 Oct 2002 03:00:00 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Error installing Libnet module

2. Error installing Libnet module

3. ActiveState VPN Libnet install error

4. Q: Errors installing URI-1.00.tar.gz over ActivePerl 509

5. Activeperl install fails Internal Error 2744

6. Can't build Net/libnet-1.0606 using ActivePerl 5.005 on Win98

7. Unexpected glob behavior nt4-ActivePerl-5.6

8. Dial-Up Connection under ActivePerl and NT4?

9. XML::Parser under NT4.0 & ActivePerl 5.6

10. Windows NT4.0 / IIS / ActivePerl 5.22

11. PerlMagick with ActivePerl (perlis.dll) on NT4 / IIS4 wont load Magick.dll for Dynaloader.pm

12. PerlMagick problems on NT4 / IIS4 with ActivePerl

 

 
Powered by phpBB® Forum Software