Problems installing perldap-1.4.1 on HPUX 11.0 
Author Message
 Problems installing perldap-1.4.1 on HPUX 11.0

Greetings,

I have run into a problem installing perldap v1.4.1 on HP-UX 11.0. Here
is the output:

==> perl Makefile.PL

PerLDAP - Perl 5 Module for LDAP
================================
Directory containing 'include' and 'lib' directory of the Netscape
LDAP Software Developer Kit (default: /usr): /usr/apps/ldapcsdk
Using LDAPv3 Developer Kit (default: yes)?  
Include SSL Support (default: yes)?  
Located multiple libraries:
 - libldap50.sl
 - libssldap50.sl
 - libprldap50.sl
Libraries to link with (default: -L/usr/apps/ldapcsdk/lib -lldap50):  
Writing Makefile for Mozilla::LDAP::API

==> make
        cc -c -I/usr/apps/ldapcsdk/include +z -D_HPUX_SOURCE -DDEBUGGING
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -Ae -DPERL_POLLUTE  -O  
-DVERSION=\"1.41\"  -DXS_VERSION=\"1.41\" +z
-I/home/support/shrivsj/perl561/lib/5.6.1/PA-RISC2.0/CORE -DLDAPV3
-DUSE_SSL API.c
cc: line 1043: warning 5004: Uninitialized variable "ctrlp" in function
"XS_Mozilla__LDAP__API_ldap_create_persistentsearch_control" (5004)
cc: line 1064: warning 5004: Uninitialized variable "ctrlp" in function
"XS_Mozilla__LDAP__API_ldap_create_sort_control" (5004)
cc: line 1103: warning 5004: Uninitialized variable "ctrlp" in function
"XS_Mozilla__LDAP__API_ldap_create_virtuallist_control" (5004)
cc: line 1311: warning 5004: Uninitialized variable "retdatap" in
function "XS_Mozilla__LDAP__API_ldap_extended_operation_s" (5004)
cc: line 1799: warning 5004: Uninitialized variable "cachep" in function
"XS_Mozilla__LDAP__API_ldap_memcache_get" (5004)
cc: line 1823: warning 5004: Uninitialized variable "cachep" in function
"XS_Mozilla__LDAP__API_ldap_memcache_init" (5004)
cc: line 2251: warning 5004: Uninitialized variable "retdatap" in
function "XS_Mozilla__LDAP__API_ldap_parse_extended_result" (5004)
cc: line 2329: warning 5004: Uninitialized variable "servercredp" in
function "XS_Mozilla__LDAP__API_ldap_parse_sasl_bind_result" (5004)
cc: line 2544: warning 5004: Uninitialized variable "servercredp" in
function "XS_Mozilla__LDAP__API_ldap_sasl_bind_s" (5004)
Running Mkbootstrap for Mozilla::LDAP::API ()
        chmod 644 API.bs
        rm -f blib/arch/auto/Mozilla/LDAP/API/API.sl
        LD_RUN_PATH="/usr/apps/ldapcsdk/lib" ld  -b +vnocompatwarnings
-L/usr/local/lib API.o  -o blib/arch/auto/Mozilla/LDAP/API/API.sl  
-L/usr/apps/ldapcsdk/lib -lldap50  
ld: error 3069, parm "/usr/apps/ldapcsdk/lib/libldap50.sl"
*** Error exit code 1

Stop.

==> env | grep LD
LD_LIBRARY_PATH=/u01/app/oracle/product/8.1.6/lib:/usr/apps/ldapcsdk/lib

I am using the iplanet LDAP C SDK for HP, v5.0 optimized. I have
verified that ldapsearch works.
I have perl 5.6.1 compiled correctly(!) for use with DBI v1.21 and
DBD::Oracle v1.12 (connecting to Oracle 8.1.6).

Hopefully someone (related to Mozilla) has seen this linker problem and
has a solution! :-)

TIA & Smile,
Steve



Wed, 11 Aug 2004 06:58:17 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Problems installing GD.pm on HPUX 11.0

2. compilin perl hpux 11.0 problem

3. DB_File ok on HPUX 11.0 ?

4. Problems installing Authen::TacacsPlus on HP-UX 11.0

5. Net::Telnet module - broken on HPUX 11.0 after some OS patches were applied

6. Problems attempting to install HTML::Parser on HP-UX 11.0

7. 5.005 Under HPUX 11.0 - help!

8. GD 1.30 Compile Problem on HPUX 11

9. Perldap 1.41 on Solaris 2.8 install problems

10. INSTALL: 5.003 DynaLoader trouble on ConvexOS 11.0

11. INSTALL: 5.003 DynaLoader trouble on ConvexOS 11.0

12. MailTools-1.11 install problems

 

 
Powered by phpBB® Forum Software