Newbie: tests error in libnet-1.0704 
Author Message
 Newbie: tests error in libnet-1.0704

I am trying to install libnet-1.0704 module on my RedHat 6.2
but I end up with a problem repoted during "make test" :

PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib
-I/usr/lib/perl5/5.00503/i386-linux -I/usr/lib/perl5/5.00503 -e 'use

t/ftp...............ok
t/hostname..........ok
t/nntp..............skipping test on this platform
t/require...........FAILED tests 8-9
        Failed 2/11 tests, 81.82% okay
t/smtp..............skipping test on this platform
Failed Test  Status Wstat Total Fail  Failed  List of failed
-------------------------------------------------------------------------------
t/require.t                  11    2  18.18%  8-9
2 tests skipped.
Failed 1/5 test scripts, 80.00% okay. 2/19 subtests failed, 89.47% okay.
make: *** [test_dynamic] Error 29

What I shall I do to get rid of this error message?
I must have missed a point when answering to the questions
for building the config file?

Thanks for any explanation



Fri, 20 Feb 2004 20:18:55 GMT  
 Newbie: tests error in libnet-1.0704

Quote:

> I am trying to install libnet-1.0704 module on my RedHat 6.2
> but I end up with a problem repoted during "make test" :

> PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib
> -I/usr/lib/perl5/5.00503/i386-linux -I/usr/lib/perl5/5.00503 -e 'use

> t/ftp...............ok
> t/hostname..........ok
> t/nntp..............skipping test on this platform
> t/require...........FAILED tests 8-9
>    Failed 2/11 tests, 81.82% okay

These are two tests that just require() Net::SNPP and Net::PH.

However, these have been removed from the distribution since v1.0704 but are
still included in the test-suit (I wonder whether this isn't sort of a bug).
Just install those two modules before makeing test of libnet and it should
eventually work.

Tassilo
--
$a=[(74,116)];$b=[($a->[1]-1,$a->[1]++,0x20)];$c=[(97,110)];$d=[($c->

(chr($_)):print;}}$c=sub{$l=shift;[(0x20+$l-1,0x50,0x65,0x73-0x01,108


ord(chr($h->{$_}))))};



Sat, 21 Feb 2004 00:14:00 GMT  
 Newbie: tests error in libnet-1.0704

Quote:
> These are two tests that just require() Net::SNPP and Net::PH.

> However, these have been removed from the distribution since v1.0704 but are
> still included in the test-suit (I wonder whether this isn't sort of a bug).
> Just install those two modules before makeing test of libnet and it should
> eventually work.

Aren't these modules a part of libnet?  How can I install them outside of libnet?


Mon, 23 Feb 2004 00:16:41 GMT  
 Newbie: tests error in libnet-1.0704

Quote:

>>These are two tests that just require() Net::SNPP and Net::PH.

[...]

Quote:
> Aren't these modules a part of libnet?  How can I install them outside of libnet?

No, not any longer. I suppose you can install them just like any other
module:

perl -MCPAN -e 'install Net::SNPP'
perl -MCPAN -e 'install Net::PH'

Tassilo

--
$a=[(74,116)];$b=[($a->[1]-1,$a->[1]++,0x20)];$c=[(97,110)];$d=[($c->

(chr($_)):print;}}$c=sub{$l=shift;[(0x20+$l-1,0x50,0x65,0x73-0x01,108


ord(chr($h->{$_}))))};



Mon, 23 Feb 2004 00:51:47 GMT  
 Newbie: tests error in libnet-1.0704

Quote:


> > I am trying to install libnet-1.0704 module on my RedHat 6.2
> > but I end up with a problem repoted during "make test" :

> > PERL_DL_NONLAZY=1 /usr/bin/perl -Iblib/arch -Iblib/lib
> > -I/usr/lib/perl5/5.00503/i386-linux -I/usr/lib/perl5/5.00503 -e 'use

> > t/ftp...............ok
> > t/hostname..........ok
> > t/nntp..............skipping test on this platform
> > t/require...........FAILED tests 8-9
> >       Failed 2/11 tests, 81.82% okay

> These are two tests that just require() Net::SNPP and Net::PH.

> However, these have been removed from the distribution since v1.0704 but are
> still included in the test-suite (I wonder whether this isn't sort of a bug).
> Just install those two modules before makeing test of libnet and it should
> eventually work.

> Tassilo

This is certainly a bug, as the tests require modules which are
neither part of libnet nor required by it.  I imagine this was an
oversight, as these were recently moved from libnet to their own
distributions (changes 615 and 618 in the ChangeLog).

The fix, if you don't want to install those modules, is to edit
t/require.t to remove the tests for them.  Change "1..11" to "1..9" in
the first line, then remove the two lines for tests 8 and 9:

eval { require Net::SNPP; } || print "not "; print "ok ",$i++,"\n";
eval { require Net::PH; } || print "not "; print "ok ",$i++,"\n";

Then `make test` will succeed and you can `make install`.
Alternatively, since the only two errors you got were bogus, you could
just ignore them and `make install`.

Michael Stassen
University Information Technology Services
Indiana University Bloomington



Mon, 01 Mar 2004 23:58:14 GMT  
 
 [ 5 post ] 

 Relevant Pages 

1. Need libnet-1.0704.tar.gz installed, will pay.

2. libnet -- Net::NNTP test fails

3. make test fails on libnet-1.0605

4. libnet and Solaris 8, fails tests, unable to install

5. libnet 1.0704 Install Test 8&9 Fail

6. Need Help: libnet-1.0703 Net::SMTP tests fail

7. Domain.pm errors in libnet-1.0604

8. h2xs -Oxan Test test.h -- parenth error

9. Error with Libnet

10. Error installing Libnet module

11. Error installing Libnet module

12. ActiveState VPN Libnet install error

 

 
Powered by phpBB® Forum Software