problem with modules in a compiled perl script 
Author Message
 problem with modules in a compiled perl script

I've compiled a simple perl script which uses the Telnet module. However
when I try to execute the binary, I get the following error message:

Can't locate object method "new" via package "Net::Telnet".

The script works fine and perlcc compiles the source without any
problems.  What am I missing?  I searched the FAQ to no avail.
I've even compiled the Telnet.pm file into a shared library and tried
to link the two; no luck.

thanks

-charles



Thu, 19 Apr 2001 03:00:00 GMT  
 problem with modules in a compiled perl script
Forgot to mention, I'm using perl5.005_02.

thanks.


: I've compiled a simple perl script which uses the Telnet module. However
: when I try to execute the binary, I get the following error message:

: Can't locate object method "new" via package "Net::Telnet".

: The script works fine and perlcc compiles the source without any
: problems.  What am I missing?  I searched the FAQ to no avail.
: I've even compiled the Telnet.pm file into a shared library and tried
: to link the two; no luck.

: thanks

: -charles



Thu, 19 Apr 2001 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. problem with modules in a compiled perl script

2. How to compile perl script into .exe file with a module

3. Compiling Perl script w/modules

4. permission problem when running make with Perl modules (compiling slash)

5. compiling module compiles PERL?!?

6. compiling module compiles PERL?!?

7. Problem compiling perl script

8. problem with compiled perl script

9. problems: compiling module with nmake

10. perlcc module compile problem

11. Problem compiling module

12. Problem in compiling a SWIG module

 

 
Powered by phpBB® Forum Software