Can't locate auto/Sybase/DBlib/dbcdm.al in sybperl-2.10? 
Author Message
 Can't locate auto/Sybase/DBlib/dbcdm.al in sybperl-2.10?

Hi,
    I have just installed sybperl-2.10.  The make test & make install went
well. Here is my test script with just 4 lines using DBlib.

[1] #!/usr/local/bin/perl

[2] use Sybase::DBlib;

[3] $dbh = new Sybase::DBlib 'user', 'pwd, 'server', 'database';
[4] $dbh->dbcdm("select * from test\n");

At line [4] I get the following error:


/usr/local/lib/perl5/5.00502/sun4-solaris /usr/local/lib/perl5/5.00502
/usr/local/lib/perl5/site_perl/5.005/sun4-solaris
/usr/local/lib/perl5/site_perl/5.005 .) at test3.pl line 6

Anyone knows what to do?

Thanks,
Tiep



Sun, 26 Aug 2001 03:00:00 GMT  
 Can't locate auto/Sybase/DBlib/dbcdm.al in sybperl-2.10?

Quote:

> [4] $dbh->dbcdm("select * from test\n");

> At line [4] I get the following error:


> Anyone knows what to do?

Yeah - spell the method names correctly ;-)

It's dbcmd, not dbcdm.

Michael
--
Michael Peppler         -||-  Data Migrations Inc.

Int. Sybase User Group  -||-  http://www.isug.com



Sun, 26 Aug 2001 03:00:00 GMT  
 Can't locate auto/Sybase/DBlib/dbcdm.al in sybperl-2.10?


Quote:
>Hi,
>    I have just installed sybperl-2.10.  The make test & make install went
>well. Here is my test script with just 4 lines using DBlib.

>[1] #!/usr/local/bin/perl

>[2] use Sybase::DBlib;

>[3] $dbh = new Sybase::DBlib 'user', 'pwd, 'server', 'database';
>[4] $dbh->dbcdm("select * from test\n");

>At line [4] I get the following error:


>/usr/local/lib/perl5/5.00502/sun4-solaris /usr/local/lib/perl5/5.00502
>/usr/local/lib/perl5/site_perl/5.005/sun4-solaris
>/usr/local/lib/perl5/site_perl/5.005 .) at test3.pl line 6

>Anyone knows what to do?

Is the SYBASE environment variable set?
(you can force this in your script with something like:
BEGIN
$ENV{SYBASE}="/usr/sybase"
END

do not forget the BEGIN part, it will execute before anythin else)

__________________________________________________
"Nothing is as subjective as reality"

http://www.xs4all.nl/~reinoud
__________________________________________________



Mon, 27 Aug 2001 03:00:00 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Can't locate auto/LWP/UserAgent/_need_proxy.al

2. Can't locate auto/Net/FTP/logon.al

3. Can't locate auto/Socket/new.al

4. newbie Can't locate auto/Tk/Widget/Construct.al

5. Can't locate auto/Digest/MD5/require_ver.al in @INC

6. can't locate Sybase/DBLIB in @INC

7. Problems with XS, Can't locate auto/DynaLoader/dl_findfile.al

8. Can't locate auto/Socket/new.al

9. newbie Can't locate auto/Tk/Widget/Construct.al

10. Sybase DBlib/Sybperl/Sybase CTlib tutorial.

11. Sybase 10, Irix 5.2, sybperl

12. sybase extenstions to perl (Sybase::DBlib)

 

 
Powered by phpBB® Forum Software