Failure to install Image::Magick 
Author Message
 Failure to install Image::Magick

I'm attempting to use Image::Magick on my Linux server, but I needed to
install it first. I got the Imagemagick sources (I tried both 5.3.8.2
and 5.3.9), and tried to install them with ./configure. That seemed to
work alright, apart from the fact that installation of PerlMagick (as
part of the above sources) failed. I *think* ImageMagick itself got
installed alright. (The installation instructions on Imagemagick appear
to be incomplete.)

Then I tried the PerlMagic 5.3.9 distribution from CPAN. The same thing
happened.

I get these error messages:

Running Mkbootstrap for Image::Magick ()
chmod 644 Magick.bs
LD_RUN_PATH="/usr/lib:/usr/X11R6/lib" cc -o
blib/arch/auto/Image/Magick/Magick.s
o  -shared -L/usr/local/lib Magick.o    -L/usr/lib -L/usr/local/lib
-L/usr/X11R6
/lib -lMagick -ltiff -lfreetype -lpng -lXext -lXt -lSM -lICE -lX11 -lbz2
-lz -lp
thread -lm
/usr/bin/ld: cannot open -lXext: No such file or directory
collect2: ld returned 1 exit status
make: *** [blib/arch/auto/Image/Magick/Magick.so] Error 1

It seems to me as if installation fails because it can't find the X11
libraries. Huh?!?  Why on earth would Image::Magick, the perl module,
need the X libraries anyway? I thought Imagemagick's configure reported
that it got built without X support. So why would perl want it?

(BTW a file "libXext.so.6" exists under /usr/lib/X11R6/lib)

So what do I do wrong, how do I fix it?

--
        Bart.



Mon, 08 Mar 2004 08:26:43 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Image Magick finding image size without loading image

2. Need help with Perl::Magick (Image::Magick)

3. Can't load Magick.so for module Image::Magick

4. Failed to install Image::Magick

5. Image::Magick install issue : libperl.a

6. Image::Magick install failing

7. solution: installing Image::Magick to host as non-root user

8. Image::Magick : unable to install/compile/use it

9. still problems installing Image::Magick to non-root target

10. Installing Image::Magick

11. Image::Magick: unable to install on Solaris 2.6/Sparc

12. Image::Magick: unable to install on Solaris 2.6/Sparc

 

 
Powered by phpBB® Forum Software