GD install problem, can't find gd.h 
Author Message
 GD install problem, can't find gd.h

I have been trying to install GD.pm through both the perl -MCPAN shell
and from source files.
Here is the exact error:

gcc -c -I/usr/local/include -I/usr/local/include/gd -D_REENTRANT
-fno-strict-aliasing -I/usr/local/include -D_LARGEFILE_SOURCE
-D_FILE_OFFSET_BITS=64 -O2   -DVERSION=\"1.33\" -DXS_VERSION=\"1.33\"
-fpic -I/usr/local/ActivePerl-5.6/lib/5.6.1/i686-linux-thread-multi/CORE
-DHAVE_JPEG -DHAVE_TTF -DHAVE_XPM GD.c
GD.xs:7: gd.h: No such file or directory
make: *** [GD.o] Error 1

I have installed the latest libpng and zlib as suggested, I even updated
my perl installation.  Sure enough, even in the download src for GD I
cannot find the gd.h file.  Anyone have a clue as to my brain fart
here?  Tx!

Joel

< People helping people >



Wed, 19 Nov 2003 11:34:01 GMT  
 GD install problem, can't find gd.h
On Sat, 02 Jun 2001 03:34:01 GMT,

Quote:
> I have been trying to install GD.pm through both the perl -MCPAN shell
> and from source files.
> Here is the exact error:

[snip]

Quote:
> GD.xs:7: gd.h: No such file or directory
> make: *** [GD.o] Error 1

> I have installed the latest libpng and zlib as suggested, I even updated
> my perl installation.  Sure enough, even in the download src for GD I
> cannot find the gd.h file.  Anyone have a clue as to my brain fart
> here?  Tx!

You need to install libgd, as mentioned in the README that comes with GD
1.33.

Quote:
>< People helping people >

huh?

Martien
--
Martien Verbruggen              |
Interactive Media Division      | Hi, Dave here, what's the root
Commercial Dynamics Pty. Ltd.   | password?
NSW, Australia                  |



Wed, 19 Nov 2003 12:54:31 GMT  
 GD install problem, can't find gd.h

Quote:

> > I have been trying to install GD.pm through both the perl -MCPAN shell
> > and from source files.
> > Here is the exact error:
> [snip]
> > GD.xs:7: gd.h: No such file or directory
> > make: *** [GD.o] Error 1
> > I have installed the latest libpng and zlib as suggested, I even updated
> > my perl installation.  Sure enough, even in the download src for GD I
> > cannot find the gd.h file.  Anyone have a clue as to my brain fart
> > here?  Tx!

> You need to install libgd, as mentioned in the README that comes with GD
> 1.33.

Indeed.  I was so caught up in reading the zlib, freetype2, and libpng stuff I
completely
lost my mind. It is as you say.  Since then I have painfully installed zlib
and libpng.  Have
had no luck with freetype.  I think GD installed although I haven't got it
usable yet. Can't
seem to get GD::Graph to install at all and I want to get to GD::Graph3d.  Me
thinks the
open source world is moving too fast for me. :-(   However, I will perservere.

Quote:
> >< People helping people >

> huh?

That's what YOU are doing!

Joel



Thu, 20 Nov 2003 00:38:06 GMT  
 GD install problem, can't find gd.h

  > I have been trying to install GD.pm through both the perl -MCPAN shell
  > and from source files.
  > Here is the exact error:
  [snip]
  > GD.xs:7: gd.h: No such file or directory
  > make: *** [GD.o] Error 1
  > I have installed the latest libpng and zlib as suggested, I even updated
  > my perl installation.  Sure enough, even in the download src for GD I
  > cannot find the gd.h file.  Anyone have a clue as to my brain fart
  > here?  Tx!

  You need to install libgd, as mentioned in the README that comes with GD
  1.33.

Indeed.  I was so caught up in reading the zlib, freetype2, and libpng stuff
I completely
lost my mind. It is as you say.  Since then I have painfully installed zlib
and libpng.  Have
had no luck with freetype.  I think GD installed although I haven't got it
usable yet. Can't
seem to get GD::Graph to install at all and I want to get to GD::Graph3d.
Me thinks the
open source world is moving too fast for me. :-(   However, I will
perservere.

  >< People helping people >

  huh?

That's what YOU are doing!

Joel



Thu, 20 Nov 2003 00:40:51 GMT  
 GD install problem, can't find gd.h

Quote:
> Indeed.  I was so caught up in reading the zlib, freetype2, and libpng
> stuff I completely
> lost my mind. It is as you say.  Since then I have painfully installed
> zlib
> and libpng.  Have
> had no luck with freetype.  I think GD installed although I haven't got it
> usable yet. Can't
> seem to get GD::Graph to install at all and I want to get to GD::Graph3d.
> Me thinks the
> open source world is moving too fast for me. :-(   However, I will
> perservere.

It's times like these I'm grateful I've got ActiveState's ppm capabilities.
I can't even get to the jpeg library for one of the GD modules - the page
has been down.  Major headache all around trying to install this stuff
manually.

"ppm> install GD"

Works like a charm (ok, so it's ONLY version 1.27, but still).

Regards,

Dan



Thu, 27 Nov 2003 10:22:09 GMT  
 
 [ 5 post ] 

 Relevant Pages 

1. GD: Problem in installing GD 1.20-1.27

2. GD.pm problems, can't install and I need it

3. GD - problems in creating GD.pl

4. Problems with GD->plot() using GD::Barcode::UPCE

5. Problems Making GD.pm (GD-1.22)

6. Can't find loadable object for GD in @INC

7. perl can't find GD Module

8. Can't find loadable object for module GD

9. Seeking help installing GD.pm (I know, I'm just one of a thousand)

10. help can't install perl GD module!

11. GD.pm doesn't install

12. Clueless newbie can't install GD-1.16 / TK

 

 
Powered by phpBB® Forum Software