Error with Libnet 
Author Message
 Error with Libnet

I have a production server with perl running on it and all
of a sudden the Net::SMTP started to error like this..

bash-2.04# perl -e "use Net::SMTP"
Can't declare undef operator in my at
/usr/local/lib/perl5/site_perl/Net/Cmd.pm line 500, near ")
="
BEGIN failed--compilation aborted at
/usr/local/lib/perl5/site_perl/Net/SMTP.pm line 16.
BEGIN failed--compilation aborted at -e line 1.

Any suggestions would greatly appreciated...

--------------------------------------
   This Article Was brought to you by
               WebNews
    A Netwin Web Based News Client
  http://www.*-*-*.com/



Sat, 22 Jan 2005 07:17:53 GMT  
 Error with Libnet

Quote:

> I have a production server with perl running on it and all
> of a sudden the Net::SMTP started to error like this..

> bash-2.04# perl -e "use Net::SMTP"
> Can't declare undef operator in my at
> /usr/local/lib/perl5/site_perl/Net/Cmd.pm line 500, near ")
> ="
> BEGIN failed--compilation aborted at
> /usr/local/lib/perl5/site_perl/Net/SMTP.pm line 16.
> BEGIN failed--compilation aborted at -e line 1.

> Any suggestions would greatly appreciated...

> --------------------------------------
>    This Article Was brought to you by
>                WebNews
>     A Netwin Web Based News Client
>  http://netwinsite.com/webnews/tag.htm

Hmmm ... I looked at my copy of the Net::Cmd module and its rather odd
that it should be failing at line 500, since that line appears to be in
the middle of some imbedded pod docs. Specifically, my line 500 of this
module reads:

   Returns undef upon failure

Though I did notice something funny about the path to your Net::Cmd
module. It's in the general site_perl directory instead of the
architecture specific directory. Not sure if that should make a
difference, but if someone messed with the setup and put another copy of

What version of libnet did you install? What version of Perl are you using?

Pete



Sat, 22 Jan 2005 07:36:32 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Domain.pm errors in libnet-1.0604

2. Newbie: tests error in libnet-1.0704

3. Error installing Libnet module

4. Error installing Libnet module

5. MAKE Error installing Libnet+POP3Client with ActivePerl on NT4

6. ActiveState VPN Libnet install error

7. Libnet: NNTP result error

8. time format in libnet module

9. libnet package

10. mget in libnet-1.0605

11. libnet-1.0605 proxy question

12. Libnet 1.0605: Need server-response codes from Net::FTP

 

 
Powered by phpBB® Forum Software