problems with activePerl ppm install to non-root? 
Author Message
 problems with activePerl ppm install to non-root?

I am trying to emulate module installation on a windows98 machine with a
directory structure identical to what will be on a remote webserver
where I do not have root privs and must install modules under my
cgi-bin.

One of the modules (Image-Magick) is a real bear to build and install on
a PC using CPAN, but pretty easy using the ActiveState ppm utility that
is included in the perl install. It has all the ImageMagic binaries
pre-compiled and everything seems to work just fine if modules are
installed to the "normal" location in the perl install tree.

However, things DONT seem to get set up completely correctly when
installed elsewhere. The modules dont get found, and manual tweaking of

If anyone has had success with installing and using modules installed
with ppm to a folder outside the perl install.... please post your tips!

thanx,

Dan

Sent via Deja.com http://www.*-*-*.com/
Before you buy.



Sat, 12 Apr 2003 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. still problems installing Image::Magick to non-root target

2. non-root installing modules?

3. installing modules to a non-root dir on webserver

4. non root module install on FreeBSD-3.2

5. solution: installing Image::Magick to host as non-root user

6. installing module as non-root

7. solution: installing Image::Magick to host as non-root user

8. installing via ppm on activeperl 5.8

9. ActivePerl Modules won't install with ppm on standalone system

10. ActivePerl ppm install DB_File on NT

11. ActivePerl ppm install DB_File on NT

12. non-ascii characters in ActivePerl-problem

 

 
Powered by phpBB® Forum Software