Image::Magick: unable to install on Solaris 2.6/Sparc 
Author Message
 Image::Magick: unable to install on Solaris 2.6/Sparc


Quote:
> I'm trying to use the highly-advocated Image::Magick libraries to scribble
> on JPEG files. The PerlMagick test suite that comes with the full
> distribution is failing on JPEG altho' succeeds on the other:

> # perl -MImage::Magick -e '$i = new Image::Magick; $x =
> $i->Read("t/jpeg/input.jpg"); warn $x if $x;'
> Warning 320: JPEG library is not available (t/jpeg/input.jpg) [No such file
> or directory] at -e line 1.
> #

make sure that you followed the compilation instrustions precisely.
there is a separate directory in the distribution that holds the
jpeg stuff.  make sure you have it and followed its instructions as
well.

good luck :)

--

CGI Meta FAQ <URL: http://www.*-*-*.com/ ;
remove NOSPAM or don't.  it doesn't matter either way.



Fri, 08 Jun 2001 03:00:00 GMT  
 Image::Magick: unable to install on Solaris 2.6/Sparc
brian d foy wrote  ...

Quote:

>> I'm trying to use the highly-advocated Image::Magick libraries to
scribble
>> on JPEG files. The PerlMagick test suite that comes with the full
>> distribution is failing on JPEG altho' succeeds on the other:

>> # perl -MImage::Magick -e '$i = new Image::Magick; $x =
>> $i->Read("t/jpeg/input.jpg"); warn $x if $x;'
>> Warning 320: JPEG library is not available (t/jpeg/input.jpg) [No such
file
>> or directory] at -e line 1.
>> #

>make sure that you followed the compilation instrustions precisely.
>there is a separate directory in the distribution that holds the
>jpeg stuff.  make sure you have it and followed its instructions as
>well.

Thanks.. I didn't spot that. As it turns out though since I was building for
shared libraries for all of zlib, jpeg and Magick moving the zlib/jpeg
directories inside ImageMagick-4.1.6 wasn't necessary: just making sure
/usr/local/lib was on the -L list.

What swung it was running make install in the ImageMagick-4.1.6 directory
_before_ attempting the PerlMagick regression tests (as in fact is suggested
implicitly in the docs). Doh!

Paul

--
Paul Makepeace, Independent Thinkers Ltd (UK)
0171 377 8668 / 0973 800436
"People are all monkeys, and I am Captain Banana"
 -- Vincent Gallo



Sat, 09 Jun 2001 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Image::Magick: unable to install on Solaris 2.6/Sparc

2. install problem on Solaris 2.6 ( sparc )

3. Image::Magick : unable to install/compile/use it

4. Binaries for DBD-Oracle on Solaris 2.6 SPARC

5. Searching perl package for SPARC Solaris 2.6, please

6. installing Image::Size 2.6

7. Prlbm installing sybperl on Solaris 2.6.

8. Prble installing sybperl 2.13 on solaris 2.6.

9. installing perl under solaris 2.6

10. Help with Installing PERL on Solaris 2.6

11. Installing Perl5.004 Solaris 2.6

12. Install Errors: 5.005_02 on Solaris 2.6 system

 

 
Powered by phpBB® Forum Software