Perl, XML Parser and Expat 
Author Message
 Perl, XML Parser and Expat

Dear Friends,
I need to use XML Parser and consequently Expat with Perl.
I succedeed doing it in Linux, but I'm experiencing some problems with
Windows XP.
I've first of all installed ActiveState Active Perl 5.6, which seems to work
perfectly.
Then, I dowloaded and installed (by clicking on the executable) expat 1.95.5
windows version.
Then, I dowloaded and expanded XMLParser2.31.tar.gz and expanded it.
Then, if I execute
perl Makefile.pl
it says to me:
Note(probably harmless): no library found for '-lexpat'
Then, when I run nmake,
it says
"Fatal error, cannot open include file 'expat.h': no such file or
directory".

I also tried to add the environemnt variable PERLLIB, and also I tried to
add the correct EXPATLIBPATH and EXPATINCPATH as suggested in the readme
file, but I'm not able to solve this.
Any help would be greatly appreciated.

Thanks in advance,

Francesco



Sat, 26 Mar 2005 21:26:53 GMT  
 Perl, XML Parser and Expat

Quote:

>I need to use XML Parser and consequently Expat with Perl.
>I succedeed doing it in Linux, but I'm experiencing some problems with
>Windows XP.
>I've first of all installed ActiveState Active Perl 5.6, which seems to work
>perfectly.
>Then, I dowloaded and installed (by clicking on the executable) expat 1.95.5
>windows version.

Why go through all the trouble? Activestate Perl comes with XML::Parser
pre-installed.

--
        Bart.



Sun, 27 Mar 2005 02:48:15 GMT  
 Perl, XML Parser and Expat



Quote:

> >I need to use XML Parser and consequently Expat with Perl.
> >I succedeed doing it in Linux, but I'm experiencing some problems with
> >Windows XP.
> >I've first of all installed ActiveState Active Perl 5.6, which seems to
work
> >perfectly.
> >Then, I dowloaded and installed (by clicking on the executable) expat
1.95.5
> >windows version.

> Why go through all the trouble? Activestate Perl comes with XML::Parser
> pre-installed.

Ach .. I didn't know. In any case, how to install expat in this case ?
The instruction I found on the Net, say that XML::Parser has to be installed
AFTER expat. Have I to uninstall Activestate Perl, install expat, and then
install Perl again ?

francesco



Sun, 27 Mar 2005 08:15:36 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. XML::Parser/XML::Parser::Expat

2. XML-PARSER-2_30 expat compile expat.h missing

3. Expat XML:Parser install and Running ActivePerl and IndigoPerl

4. Expat and xml::parser on windows server.

5. XML-Parser and Expat

6. Newbie Question: XML::Parser & Expat build problems

7. expat: XML::Parser

8. expat XML parser

9. XML::Parser::Expat

10. Solution: Building expat-1.95.2 for perl (For XML::Parse)

11. PROPOSAL: XML::Lite Light-weight, pure-perl, XML Parser

12. Newbie: XML::DOM and Expat

 

 
Powered by phpBB® Forum Software