Newbie LWP::Simple installation problem 
Author Message
 Newbie LWP::Simple installation problem

Hi.
I'm kinda new to Perl, although I have used it a little before. I'm
trying to install LWP::Simple on my ActivePerl 5.6 installation under
Windows ME, and it isn't working. Here's what I've done so far:
I ran "perl -MCPAN -e "install LWP::Simple"". The CPAN installer
prompted me for details such as my gzip, tar and make programs. I'm
using Microsoft nmake 1.5.
This went ok, and it started the LWP::Simple installation,which stated I
didn't have Net::FTP, which the CPAN installer installed just fine. So I
continued with the LWP::Simple installation. I thought things seemed odd
in that it seemed to want to install to c:\perl\site\lib and
c:\perl\site\bin, not c:\perl\lib and c:\perl\bin.
So it continues to install, runs make, until make freezes at:
         C:\Perl\bin\perl.exe -IC:\Perl\lib -IC:\Perl\lib  -e "system
qq[pl2bat.bat ].shift" blib\script\POST
with just "PERL" in the title bar. ^C causes make to terminate, with the
error "U1058. Stop." Probably because I just stopped it.

So can anyone tell me why it freezes while making this file? Thanks.

Nick



Sun, 29 May 2005 19:12:28 GMT  
 Newbie LWP::Simple installation problem
On Wed, 11 Dec 2002 22:12:28 +1100,

Quote:
> Hi.
> I'm kinda new to Perl, although I have used it a little before. I'm
> trying to install LWP::Simple on my ActivePerl 5.6 installation under
> Windows ME, and it isn't working. Here's what I've done so far:
> I ran "perl -MCPAN -e "install LWP::Simple"". The CPAN installer

When using ActiveState Perl, it is probably better to use their ppm tool
that comes as part of their bundle.

Martien
--
                        |
Martien Verbruggen      | Useful Statistic: 75% of the people make up
                        | 3/4 of the population.
                        |



Sun, 29 May 2005 19:42:09 GMT  
 Newbie LWP::Simple installation problem
I tried that, but couldn't find the LWP::Simple package anywhere.

Nick

Quote:

> On Wed, 11 Dec 2002 22:12:28 +1100,

>>Hi.
>>I'm kinda new to Perl, although I have used it a little before. I'm
>>trying to install LWP::Simple on my ActivePerl 5.6 installation under
>>Windows ME, and it isn't working. Here's what I've done so far:
>>I ran "perl -MCPAN -e "install LWP::Simple"". The CPAN installer

> When using ActiveState Perl, it is probably better to use their ppm tool
> that comes as part of their bundle.

> Martien



Sun, 29 May 2005 20:13:20 GMT  
 Newbie LWP::Simple installation problem

Please don't top-post. I makes it difficult to follow the article.  I
reordered it so the next reader can see what your reply is referring to.

Quote:

>> On Wed, 11 Dec 2002 22:12:28 +1100,

>>> Hi.
>>> I'm kinda new to Perl, although I have used it a little before. I'm
>>> trying to install LWP::Simple on my ActivePerl 5.6 installation under
>>> Windows ME, and it isn't working. Here's what I've done so far:
>>> I ran "perl -MCPAN -e "install LWP::Simple"". The CPAN installer

>> When using ActiveState Perl, it is probably better to use their ppm tool
>> that comes as part of their bundle.
>I tried that, but couldn't find the LWP::Simple package anywhere.

The LWP bundle is included as part of the ActivePerl distribution -- you
shouldn't need to install it.  If it isn't found with "use LWP::Simple;"
consider upgrading your ActivePerl to 5.6.1 or 5.8.0 (both currently
available).

--
EBC



Sun, 29 May 2005 21:00:09 GMT  
 Newbie LWP::Simple installation problem
Aren't the LWP packages part of the default AS Perl installation?  Did
you try "perl -MLWP::Simple -e '0'" from the command line?

Quote:

> I tried that, but couldn't find the LWP::Simple package anywhere.

> Nick


> > On Wed, 11 Dec 2002 22:12:28 +1100,

> >>Hi.
> >>I'm kinda new to Perl, although I have used it a little before. I'm
> >>trying to install LWP::Simple on my ActivePerl 5.6 installation under
> >>Windows ME, and it isn't working. Here's what I've done so far:
> >>I ran "perl -MCPAN -e "install LWP::Simple"". The CPAN installer

> > When using ActiveState Perl, it is probably better to use their ppm tool
> > that comes as part of their bundle.

> > Martien

--
Ron Reidy
Oracle DBA


Sun, 29 May 2005 21:46:14 GMT  
 Newbie LWP::Simple installation problem
On Wed, 11 Dec 2002 23:13:20 +1100, Data888

First and foremost, don't top-post.  It is rude and
inconsiderate and severely diminishes the chances
of anyone with any real knowledge giving you useful
answers.

Quote:
>>>I'm kinda new to Perl, although I have used it a little before. I'm
>>>trying to install LWP::Simple on my ActivePerl 5.6 installation under
>>>Windows ME, and it isn't working. Here's what I've done so far:
>>>I ran "perl -MCPAN -e "install LWP::Simple"". The CPAN installer

>> When using ActiveState Perl, it is probably better to use their ppm tool
>> that comes as part of their bundle.

>I tried that, but couldn't find the LWP::Simple package anywhere.

1 - LWP::Simple is part of every Activeperl install and has
been for a long time.  You shouldn't need to install
anything.

2 - If you need to install something with PPM, you
probably need to set your HTTP_proxy environment
variable.  
See perldoc ppm (or C:/Perl/html/faq/ActivePerl-faq2.html)
for details.

3 - LWP::Simple comes in a bundle called libwww-perl
so that is what you install or upgrade, not LWP::Simple
itself.
--
Regards, Helgi Briem
helgi AT decode DOT is

                           A: Top posting
                           Q: What is the most irritating thing on Usenet?
                                           - "Gordon" on apihna



Mon, 30 May 2005 19:21:46 GMT  
 
 [ 6 post ] 

 Relevant Pages 

1. How to install LWP::Simple (newbie)

2. CPAN.pm or LWP causing problems with installations

3. Installation problems - LWP: Please Help!

4. Early Perl 5.8.0 and LWP::Simple and LWP::UserAgent

5. LWP::Simple header information problems

6. problem with LWP::Simple

7. LWP::Simple Last-modified problem

8. LWP::Simple - problems with google

9. LWP::Simple header information problems

10. Simple Question - LWP::Simple not accessing the internet

11. LWP::Simple problem on mod_perl

12. LWP::Simple problem

 

 
Powered by phpBB® Forum Software