still problems installing Image::Magick to non-root target 
Author Message
 still problems installing Image::Magick to non-root target

I have tried numerous different approaches, and am still not able to use
Image::Magick . At this point I am so confused I cant tell where I am
going wrong. I need to install and configure to run from a subdir of my
cgi-bin dir because I do not have root privs on my remote ISP domain
host and cannot install to /usr.

my ISP host is a LINUX box, and the target dir I want to install to is
/home/normsgallery/www/admin/cgi-bin

I will note my procedure.... PLEASE tell me where I am going wrong!

- I uploaded ImageMagick-5_2_4.gz
- telnet in and :
$ cd /home/normsgallery/www/admin/cgi-bin
$ gzip -d ImageMagick-5_2_4.gz
$ tar -xof ImageMagick-5_2_4_tar
$ cd ImageMagick-5.2.4
$ configure --without-perl --prefix=/home/normsgallery/www/admin/cgi-bin
$ cd PerlMagick
$ perl Makefile.PL PREFIX=/home/normsgallery/www/admin/cgi-bin
$ make
$ make test
$ make install

...note that the $ make test give warnings:

/usr/local/bin/perl -Iblib/arch -Iblib/lib
-I/usr/lib/perl5/5.00503/i386-linux -I/usr/lib/perl5/5.00503 -e 'use

 t/jpeg/*.t t/png/*.t t/ps/*.t t/tiff/*.t t/x/*.t t/zlib/*.t
t/filter............dubious
        Test returned status 255 (wstat 65280, 0xff00)

and the make install gives:

Skipping
/home/normsgallery/www/admin/cgi-bin/lib/perl5/site_perl/5.005/i386-linu
x/auto/Image/Magick/Magick.so (unchanged)
Skipping
/home/normsgallery/www/admin/cgi-bin/lib/perl5/site_perl/5.005/i386-linu
x/auto/Image/Magick/Magick.bs (unchanged)
Files found in blib/arch --> Installing files in blib/lib into
architecture dependend library tree!
Skipping
/home/normsgallery/www/admin/cgi-bin/lib/perl5/site_perl/5.005/i386-linu
x/Image/Magick.pm (unchanged)
Skipping
/home/normsgallery/www/admin/cgi-bin/lib/perl5/site_perl/5.005/i386-linu
x/auto/Image/Magick/autosplit.ix (unchanged)
Skipping
/home/normsgallery/www/admin/cgi-bin/lib/perl5/man/man3/Image::Magick.3
(unchanged)
Writing
/home/normsgallery/www/admin/cgi-bin/lib/perl5/site_perl/5.005/i386-linu
x/auto/Image/Magick/.packlist
Appending installation info to
/home/normsgallery/www/admin/cgi-bin/lib/perl5/5.00503/i386-linux/perllo
cal.pod

when I try to run my script, I get this error:

[Mon Oct 30 14:51:01 2000] SaveImageInfo.pl: [Mon Oct 30 14:51:01 2000]
SaveImageInfo.pl: Can't
load
'/home/normsgallery/www/admin/cgi-bin/lib/perl5/site_perl/5.005/i386-lin
ux/auto/Image/Magick/Magick.so'
for module Image::Magick:
/home/normsgallery/www/admin/cgi-bin/lib/perl5/site_perl/5.005/i386-linu
x/auto/Image/Magick/Magick.so:
undefined symbol: GetImagePixels at
/usr/lib/perl5/5.00503/i386-linux/DynaLoader.pm line 169.
[Mon Oct 30 14:51:01 2000] SaveImageInfo.pl: [Mon Oct 30 14:51:01 2000]
SaveImageInfo.pl: [Mon
Oct 30 14:51:01 2000] SaveImageInfo.pl: [Mon Oct 30 14:51:01 2000]
SaveImageInfo.pl: at
subSizeAndThumb.pl line 46 BEGIN failed--compilation aborted at
subSizeAndThumb.pl line 46.

Sent via Deja.com http://www.*-*-*.com/
Before you buy.



Sat, 19 Apr 2003 03:51:35 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. solution: installing Image::Magick to host as non-root user

2. solution: installing Image::Magick to host as non-root user

3. problems with activePerl ppm install to non-root?

4. Image Magick finding image size without loading image

5. non-root installing modules?

6. installing modules to a non-root dir on webserver

7. non root module install on FreeBSD-3.2

8. installing module as non-root

9. Need help with Perl::Magick (Image::Magick)

10. Can't load Magick.so for module Image::Magick

11. Failed to install Image::Magick

12. Failure to install Image::Magick

 

 
Powered by phpBB® Forum Software