MLDBM unable to read data 
Author Message
 MLDBM unable to read data

Help if you can,

  I have a database created with MLDBM, not sure what version but if I
do a 'file' on it I get:

    Berkeley DB Hash file (Version 2, Little Endian, ...etc...

My program was migrated to a new machine and can't read the data.  I
removed the data file and let it create a new one.  'file' gives me:

    Berkeley DB 2.X Hash/Little Endian (Version 5)

The original database file on the new system gives the error:

    MLDBM error: Second level tie failed

I also tried to do a db_dump (and db_dump185), but they both fail.  I
tried different versions of MLDBM, DataDumper, DB_File, and BerkleyDB
but still nothing.  How can I get access to my data?

Thanks,
Donald S. Birtch

===========================================================================


University of Toronto at Scarborough

1265 Military Trail, R-4033
Scarborough, Ontario                      Voice: (416) 287-7618
Canada, M1C 1A4                             Fax: (416) 287-7677
===========================================================================



Sat, 24 Aug 2002 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. PROBLEM: data output w/MLDBM

2. Problem: MLDBM makes enormous DB files out of little data

3. MLDBM.pm read error

4. MLDBM Read/Write Problems

5. Perl unable to read a file on IIS

6. Need to read a html page and save it via perl Unable to Use LWP

7. Reading data from _DATA_

8. Newbie Question: cannot read data from .pl

9. PERL or C library for reading COBOL binary data files

10. Perl for reading raw data from network?

11. tokenizing when reading from a data file

12. How to read data from program ?

 

 
Powered by phpBB® Forum Software