libnet-1.0605 proxy question 
Author Message
 libnet-1.0605 proxy question

I'm trying to make test the libnet-1.0605 module and one detail escapes
me.  I don't know much about this, so my question may appear ignorant.
But, I've got a couple hours in this, and have made no progress...

The make test yeilds this output-
87 %  make test
t/ftp...............Net::FTP: No route to host at t/ftp.t line 13
FAILED tests 1-4
        Failed 4/4 tests, 0.00% okay
t/hostname..........ok
t/nntp..............ok
t/ph................skipping test on this platform
t/require...........ok
t/smtp..............ok
Failed Test  Status Wstat Total Fail  Failed  List of failed
-------------------------------------------------------------------------------
t/ftp.t                       4    4 100.00%  1-4
Failed 1/6 test scripts, 83.33% okay. 4/23 subtests failed, 82.61% okay.
make: *** [test_dynamic] Error 29

In order to use the proxy server, and get outside the corporate firewall
(from Netscape) I must enter a userid and password the first time I go
out after launching Netscape.   Netscape apparently remembers that
information for subsequent trips through the firewall until I restart
the application.

 I see nothing regarding this in the questions that are used to generate
the libnet.cfg file, nor am I prompted for this information when I run
make test.  Does that mean that this module doesn't support whatever my
firewall requires to get through it?  Or am I just missing something?

Here's a copy of my personalized lines from the libnet.cfg file-
  test_hosts => '1',
  nntp_hosts => ['thetimes.pixel.kodak.com','news'],
  snpp_hosts => [],
  pop3_hosts => ['enterprise1'],
  ftp_ext_passive => '1',
  smtp_hosts => ['mailhost'],
  ftp_testhost => 'ftp.ee.ualberta.ca',
  inet_domain => 'gerber.kodak.com',
  ph_hosts => [],
  test_exist => '1',
  daytime_hosts => [],
  ftp_int_passive => '0',
  ftp_firewall => 'proxy.kodak.com',
  time_hosts => [],

The things I'm not sure of are
  ftp_ext_passive (I've tried both yes and no)
  ftp_int_passive (I've tried both yes and no)
  inet_domain is what I got from the domainname command
  ftp_firewall I got from my Netscape setup
     (it also indicates port 81, but I didn't know what do do with that
      number)

I hope that's enough information for someone to help me without knowing
the details of our proxy server...
--

Steve Woodard  (716)-588-2069
      Pager    (716)-975-3984
Optical Storage Products 1/800/KP



Sat, 11 Nov 2000 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. mget in libnet-1.0605

2. make test fails on libnet-1.0605

3. Read FAQs but can't install libnet-1.0605

4. Is Net::FTP (libnet-1.0605) threadsafe?

5. Is Net::FTP (libnet-1.0605) threadsafe?

6. How to use libnet-1.0605 on ActiveState's win32 port?

7. Question: bind problem installing libnet

8. DBI::Proxy on Win2K - can't start proxy server with mode=threads

9. LWP / proxy question

10. YahooQuote.pm proxy question

11. DBD::Proxy question

12. Perl HTTPS proxy question

 

 
Powered by phpBB® Forum Software