open doesn't return child pid under OS/2 
Author Message
 open doesn't return child pid under OS/2

Open does not seem to return a valid pid under OS/2 when the open includes a
child process...
Example...
$childsubpid=open(COMMAND,"rsh somewhere myprog.exe|");

In this example, $chilesubpid is always assigned the value 1.  I need to
know the child pid in order to kill the process after a specified amount of
time has elapsed (managed via an alarm()).

I'm using 4.036 for OS/2.  Any ideas?  

--

Manager Advanced Treasury Analytics                              416-361-4925
Canada Trust, Toronto



Tue, 16 Dec 1997 03:00:00 GMT  
 open doesn't return child pid under OS/2

Quote:

> Open does not seem to return a valid pid under OS/2 when the open includes a
> child process...
> Example...
> $childsubpid=open(COMMAND,"rsh somewhere myprog.exe|");

> In this example, $chilesubpid is always assigned the value 1.  I need to
> know the child pid in order to kill the process after a specified amount of
> time has elapsed (managed via an alarm()).

> I'm using 4.036 for OS/2.  Any ideas?  

> --

> Manager Advanced Treasury Analytics                              416-361-4925
> Canada Trust, Toronto

Same with 5.001 here. Did you send email to Andreas?

Ilya
[Both mailed and posted]



Wed, 17 Dec 1997 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. On Windows: if ($pid = open(CHILD, "|-")) {

2. maintaining a list of child process pid's (exec winterm)

3. Knowing the pid of a fork()'ed child, really

4. pid's of 2nd generation child processes

5. SGI IRIX fork() syscall: child process doesn't terminate after exit

6. open on FIFO doesn′t return -Why?

7. Child shell script output doesn't appear

8. open'ing lynx doesn't work when called by cron

9. How to get pid of all the child processes

10. PID of backgrounded child process

11. how to determine child pid ??

12. pid of children 4 times removed

 

 
Powered by phpBB® Forum Software