perl 4 script that won't run under perl 5 
Author Message
 perl 4 script that won't run under perl 5

Hi,
    I hope that someone out there can help me with this problem.
I have a sybperl script that worke under version 4, but generates
the following error message when I run it under version 5:

Undefined format "main::OUTPUT" called at tst1 line 7.

    I have stripped down the script to a few lines to try to isolate
the problem. The script runs correctly when I substitute the firs
line with "#!/usr/local/bin/sybperl"

ps - Does anyone out there know of a tutorial on the object oriented
features of perl5?

Thanks,
- Tom Trenker

------------------------------------------------------------------
#!/usr/local/bin/perl
#####!/usr/local/bin/sybperl

open (OUTPUT,">output");
$a = 11;
$b = 22;
write OUTPUT;
$~ = 'F1';
write OUTPUT;


$a,$b



Wed, 31 Dec 1997 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Please Help:My script runs on win32, it won't run on Unix

2. My script runs on win32, it won't run on Unix

3. Please Help: My script runs on win32, it won't run on Unix

4. Perl CGI scripts won't run without -w switch (under Apache 1.3.x)

5. Perl scripts won't run on Linux

6. IIS4.0 won't run perl scripts which call external commands

7. perl script won't run correctly inside emacs

8. Server won't run Perl scripts (Fasttrack)

9. Server won't run Perl scripts

10. Cron won't run my Perl Script

11. HELP: Finger script won't run on NT Perl 5.001

 

 
Powered by phpBB® Forum Software