newline problem with formatted write 
Author Message
 newline problem with formatted write

I'm having problems with ^L newline characters at the beginning of
reports generated using the format/write constructs.

I'm using perl, version 4.0 Patch level: 36

It seems that the first time a report is generated there is no newline at the
beginning as one would expect.  However *any* subsequent report (using the
same or different filehandle) from the same program always prepends the
newline character.

Any clues, any cures???

Dick

-------------------------------------------------------------------------------
                                            _
{*filter*} Middleton                             / / Telecommunications Test Division
HP Telnet: 313-2530                       / /__   _______     South Queensferry
Phone:- (+44 | 0) 31-331 7530            / __  / / ___  /           Scotland UK
Fax:- (+44 | 0) 31-331 7443             / / / / / /__/ /

                                              / /            (         )
            (   )                            /_/          (               )
         (         )                _______                  . ~ ~ ~ ~~ .
      (               )                |
         . ~ ~ ~ ~~ .                  |
                                      /O\
-------------------------------------( o )-------------------------------------
                                       -                  I'd rather be soaring



Sun, 15 Sep 1996 21:15:34 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. format picture fields with newlines problem

2. PERLFUNC: format - declare a picture format with use by the write() function

3. PERLFUNC: format - declare a picture format with use by the write() function

4. Problems using write and formats

5. Printing newlines in format statements

6. Newlines in formats

7. reading/writing with pipes: newline question

8. newline problem with messy output - v simple problem

9. Replacing multiple occurences of newline chars with a single newline char

10. Strange problem with newline (\r\n) under Win32

11. Newline problem

12. Problem checking for newline in $_ input line

 

 
Powered by phpBB® Forum Software