HELP: Problem building perl5 on HP-UX 9.03 
Author Message
 HELP: Problem building perl5 on HP-UX 9.03

Greetings,

I am trying to build perl 5.000 on an HP735 running HP-UX 9.03.I am using
gcc-2.6.3.

After _Configure_ and _make depend_, I get an error message when doing
the _make_.

The message looks like so:

----------------
        AutoSplitting perl library
        sh writemain ext/DynaLoader/DynaLoader.a  > tmp
        sh mv-if-diff tmp perlmain.c
File perlmain.c not changed.
        `sh  cflags libperl.a perlmain.o` perlmain.c
          CCCMD =  gcc -c -DDEBUGGING    

        Making DynaLoader (static)
        gcc    -o perl perlmain.o libperl.a ext/DynaLoader/DynaLoader.a  `cat ext.libs` -lm -ldld

        Making Fcntl (dynamic)
        ld -b -o ../../lib/auto/Fcntl/Fcntl.sl Fcntl.o
ld: DP-Relative Code in file Fcntl.o - Shared Library must be Position-Independent
*** Error code 1

Stop.
*** Error code 1
Stop.
----------------

Any pointers on how to fix this would be appreciated.

Thanks,

Vishy
---
Vishy Gopalakrishnan      School of Public Health,University of Michigan
                          PGP key available upon request



Tue, 11 Nov 1997 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Problem building perl5 on HP-UX 9.03

2. Need help on Installing perl5.0 on HP9000 /735 Hpux 9.03

3. HP-UX 9.03 gives warning during test of Perl 5.000

4. Problem Building Perl5 on HP-UX

5. Problem building perl5.002b3 on HP-UX 9.01

6. Perl5 build fails for HP-UX 8

7. Building Perl5.001 on HP-UX

8. Building perl5.005 on HP-UX 10.20

9. HP-UX 9.05 Build Problem

10. Problem building 5.005.03 on HP-UX

11. Problems Building perl on HP-UX B.08.00 A 9000/43S

12. Problems building Perl/Tk (on HP-UX [solved])

 

 
Powered by phpBB® Forum Software