making 'perl' (help) 
Author Message
 making 'perl' (help)


Quote:

>| Output from "make":
>|         atscc   array.o cmd.o cons.o consarg.o doarg.o doio.o dolist.o dump.o
>| eval.o form.o hash.o malloc.o perly.o regcomp.o regexec.o stab.o str.o toke.o
>| util.o perl.o usersub.o -lseq  -o perl
>| Undefined:
>| [LOTS OF STUFF]

>It looks like you aren't getting -ldbm and -lm in your command line.
>Are you using the latest Perl (3.044 or 4.0 beta)?

I agree. Did you run Configure?

***WARNING***WARNING***WARNING***WARNING***WARNING***WARNING***WARNING***

You will have to have to change the config.sh line which says

d_castneg='define'
to
d_castneg='undef'

This changes the line in config.h
from
#define         CASTNEGFLOAT    /**/
to
/*#undef        CASTNEGFLOAT    /**/

For some reason that Configure can't figure out,
not doing this causes problems. You will either get
floating point exceptions, or other random complaints.

In particular, the tcbreak script in h2pl won't work.

I have tried this with 3.044 with both cc and atscc.
I have also tried 4.0beta with atscc only.
All on an S81 running dynix 3.0.17.9.

Quote:
>Someone with a name like yours ought to always have the latest Perl. :-)

Yeah, and the latest man too. Sequent's doesn't support MANPATH.
However, they do compress the cat files, which is nice.
--

                unknown mode: sane


Mon, 16 Aug 1993 04:52:43 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. 'making' perl

2. 'making' perl

3. Making sure 'perl -v' works

4. making 'find' follow soft links

5. Making a user's tty's STDOUT

6. dmake.exe: Error code 1, while making 'Perl.obj' and 'FreeTDS.obj'

7. perl uploading/making directory's

8. HELP: Can't get debugger to work - perl can't find perl5db.pl

9. HELP: Can't get debugger to work - perl can't find perl5db.pl

10. Help on 'perl -lne'

11. Help about perl -e '`ping server`'

 

 
Powered by phpBB® Forum Software