Problem Compiling Perl 5.001 and Curses on HPUX 
Author Message
 Problem Compiling Perl 5.001 and Curses on HPUX

I am trying to install perl 5.001 with dynamic loading and I get
an error mesage about Shared libraries not being Position-Independent.
I get a sumiliar error when I try to compile Curses for perl 5.  It
is shown below:

        ld -o ../../lib/auto/Curses/Curses.sl -b Curses.o   -lcurses
ld: DP-Relative Code in file Curses.o - Shared Library must be Position-Independ
ent
*** Error code 1

This is probably just a compiler switch that I do not know about.

Any help would be appreciated!

Thanks,


Hardware Designer                  |  Phone: (902) 421-1250
Applied Microelectronics Inc. (AMI)|    Fax: (902) 429-9983
Halifax, NS, Canada                |

--


Hardware Designer                  |  Phone: (902) 421-1250
Applied Microelectronics Inc. (AMI)|    Fax: (902) 429-9983
Halifax, NS, Canada                |



Thu, 30 Oct 1997 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Problem Compiling Perl 5.001 on HPUX 9 9000/750

2. Perl 5.001 HPUX build problem

3. problem compiling perl 5.001

4. Perl 5.001 compile problems

5. Perl 5.001 compile problem: argument doesn't match function prototype

6. problem compiling perl 5.001

7. Perl 5.001 compile problems with dynamic loading

8. Perl 5.001 on hpux 9.04

9. Problems building perly.* (compiling 5.001 for SunOS 4.1.3)

10. problem compiling perl on hpux 10.01

11. problem compiling perl 5.003 in HPUX

12. compiling perl 5.001m under HPUX v.10 - problem

 

 
Powered by phpBB® Forum Software