setuid perl script questions 
Author Message
 setuid perl script questions

Hello all...

I'm having trouble getting suid perl scripts to work right.  I'm running on
a Sun w/ SunOS 4.1.3 without the suid script patch.  I set the uid bit on, and
running it gives me the normal message about either patching the kernal or running
with a c wrapper.  Since I can't patch the kernal, I have to use the c wrapper.
I tried using Larry's suidscript and also writing my own.  Now when I run the
compiled wrapper with the suid bit on, it gives me :

Can't run setuid script with taint checks.

I'm running the normal 'perl' executable, not 'taintperl'.  Is perl not compiled
correctly?  I can't get suid sybperl scripts to work correctly either.  I can't
get around this problem, so any help is greatly appreciated.  Please email me
any replies.  Thanks!

Steve



Tue, 28 Jan 1997 23:00:03 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. setuid Perl script questions

2. Setuid-scripts, Newbie questions

3. SGI Perl setuid question

4. Perl FAQ setuid question (repost)

5. Setuid & perl question (from a newbie)

6. setuid *within* Perl script

7. perl script setuid root

8. setuid perl script

9. setuid perl scripts

10. Setuid perl scripts... no smiles in mudville

11. setuid perl scripts

12. Perl/CGI setuid script displays odd cvs checkout behavior

 

 
Powered by phpBB® Forum Software