missing 'Scrolling-fred-dialog-item' 
Author Message
 missing 'Scrolling-fred-dialog-item'

Hello,
I tried load "Pail" which is programmed in MCL 2.0....
(I guess.. because there is an application that compiled with MCL 2.0).
With MCL 4.0, I got this error

Quote:
> Error: The module "SCROLLING-FRED-DIALOG-ITEM" was required while

loading #P"SungwooHD:applications:MCL 4.0:pail:toplevel:pail-init.lisp".

Quote:
>        No file could be found for that module.
> While executing: REQUIRE

I found this comment from MCL:library:fred-compatibility.lisp
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;; ;;; ;;; A bunch of methods that delegate
from fred-window to its window-key-handler ;;; and from scrolling-fred-view
to its fred-item. ;;; Helps to compensate for the fact that fred-window no
longer inherits from fred-mixin ;;; and neither does scrolling-fred-view. In
MCL 2.0 scrolling-fred-dialog-item ;;; and fred-window did inherit from
fred-mixin. ;;; This is not the complete set of fred-mixin methods, so add
any you need.

Seems... the 'scrolling-fred-view' or 'scrolling-fred-item' doesn't
support any more?
So I simply disabled the line    (require :scrolling-fred-dialog-item)
in pail-init.lisp.
It loaded UI successfully.. but when I tried to implements demos, MCL
start complains about missing module 'scrolling-fred-dialog-item'.
In pail, there are 29 items which depend on 'scrolling-fred-dialog-item'.

In MCL reference, it says that the 'scrolling-fred-dialog-item.lisp' is in
the Library folder distributed with Macintosh Common Lisp.
However, obviously not in my 4.0 CD nor demo versio of 4.2 and 4.3 version.

How could I update these problem?
Anyone compiled 'pail' in MCL 4.0 or over?
Thanks,

Sungwoo

Sent via Deja.com http://www.*-*-*.com/
Before you buy.



Tue, 08 Apr 2003 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. I can't scroll item when the IMM of Combo box is enabled

2. Where's FRED!

3. Fred Kus's Web pages

4. Mouse wheel doesn't scroll text scroll bar

5. Why won't my scrolling canvas scroll?

6. If you missed EuroDevCon '98 you wont want to miss this

7. ToolTip's and Dialog's

8. Icons missing in 'Local' mode

9. Help 'balloons' using MFocus Dialog

10. Pwm.NoteBook - 'Color' module missing

11. tcllib: missing subdir 'config'?

12. 'grab' fails for modal dialog

 

 
Powered by phpBB® Forum Software