drand : illegal instruction ??? 
Author Message
 drand : illegal instruction ???

hi, everyone:
  i ran into a small problem here: i tried to call the fortran lib : drand
  and i 've defined it as :

    integer :: i
  real :: dtime
  real :: drand
  integer :: irand
  external fdate
  external dtime
  external drand
  external irand

....

  and later on i called it once as:

    do i=1,10
    write (*,*) int((drand(i)-1.0)*100)
  end do

   and it 's doing fine

  but later i called it again just like above,
  and it can compile, but when i ran it, it said:
  illegal instruction ???

   any suggestions will be appreciated !!!
   regards
   tong.



Wed, 18 Jun 1902 08:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Illegal Instruction Workaround

2. clipper & nt illegal instruction

3. Windows NT 3.5 Illegal Instruction

4. Any illegal instruction processing interrupts?

5. Illegal instructions

6. Why does this give illegal instruction?

7. Illegal instruction (core dumped)

8. Illegal Instruction on Mac OS X Intel

9. Illegal Instruction in Tcl_Eval()

10. 'after' causes illegal instruction errors

11. Problem with drand on Sun Fortran?

12. Instruction Speed and instruction availability

 

 
Powered by phpBB® Forum Software