Segmentation Fault on SUN Ultra1,OK on HP and DEC 
Author Message
 Segmentation Fault on SUN Ultra1,OK on HP and DEC

I am running solaris 2.5 on an Ultra 1/170 with SUN's fortran 3.0.1.  
I get a segmentation fault in a code that worked fine on both HP and DEC
workstations. I found the location (dbx) where a counter is jumping from 8 to a
huge number after 8 passes through a do loop.  The only call from the
loop is a random number generator (I have tried two different ones).
The counter is an array index and is not supposed to change in this
routine since it is called from another driver routine.

I tried compiling with the -f option thinking that perhaps it was an alignment
error --- no effect.   On the HP compiler I used the -K option which
initialized arrays and saved values from one call to another.  I do not
see an equivalent option on the SUN.  I have also compiled with the -C
option and don't get any array out of bounds until this point.  


By the way this is a brand new system and this application is critical
to my research.  

Thanks in advance for your advice,

David Hyndman
Asst. Professor
Michigan State Univ.



Sun, 19 Jul 1998 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. bug Ada Verdix SUN : segmentation fault at compil time

2. bug Ada Verdix SUN : segmentation fault at compil time

3. Segmentation Fault: When attempting to run Sun Fortran code on Linux

4. how to find segmentation fault problem with Sun f90

5. Segmentation fault using HP Fortran 90

6. Sun F90 segmentation fault

7. Comparison of f77 on Dec, Sun, and HP

8. Compilation of TCL on SUN Ultra1

9. visual works 3.1 image has segmentation fault on 2.4 kernel (red hat 8.0)

10. segmentation fault on gabage collect

11. Segmentation faults

12. Segmentation Fault while compiling Eiffel classes.

 

 
Powered by phpBB® Forum Software