Strange problem with interpolation 
Author Message
 Strange problem with interpolation

I have strange problem with interpolation.
There is one box and one viewpoint.
The way of camera is below:
       ________
      /        \
     /   ___    \
    /   /   \    \
   |   /     |   |
   |  |  box |   |
   |  |    _/    /
   |   \        /
    \   \______/
     \
      \____

in the center of scene is small box and my viewpoint
all the time should point to this box. it's easy
to calculate position and orientation for camera
even if there is no constant velocity.
i made it for 101 points (including start and stop).
for preview I used cosmo player and everything was ok.
but under worldview 2 there is some bug.
it seems that worldview at first do position
interpolation with constant orientation and then
orientation interpolation.
it looks like jumping. any idea ?
the example is here:
http://www.*-*-*.com/
and direct:
http://www.*-*-*.com/
(please click on the box when loaded)

--

WebMajster oficjalnej strony VooVoo - http://www.*-*-*.com/



Sun, 22 Jul 2001 03:00:00 GMT  
 Strange problem with interpolation
Well, I wrote an "art museum" world that had several embedded transforms.
The output (as all the other browsers I tried with it, as well as my own
check by-hand) is rotated improperly with WorldView.

I don't have a simple fix, I'm unsure why it happens in that case. But the
same thing happened in a map program where a Transform-within-a-Transform
applied an orientation change to the one applied by the parent Transform
node.

So, just for fun, why not check for parent-child Transforms (that both make
orientation changes) and rewrite the code so that the re-orientation occurs
in just one of these nodes?

To save time, you might try your code with Cosmo first.  That and blaxxun
both worked fine in this respect (for me, in a similar-sounding situation).

-  Bob Greer


Quote:
>I have strange problem with interpolation.
>There is one box and one viewpoint.
>The way of camera is below:
>       ________
>      /        \
>     /   ___    \
>    /   /   \    \
>   |   /     |   |
>   |  |  box |   |
>   |  |    _/    /
>   |   \        /
>    \   \______/
>     \
>      \____

>in the center of scene is small box and my viewpoint
>all the time should point to this box. it's easy
>to calculate position and orientation for camera
>even if there is no constant velocity.
>i made it for 101 points (including start and stop).
>for preview I used cosmo player and everything was ok.
>but under worldview 2 there is some bug.
>it seems that worldview at first do position
>interpolation with constant orientation and then
>orientation interpolation.
>it looks like jumping. any idea ?
>the example is here:
>http://www.abx.bmt.com.pl/rapa/rapa.html
>and direct:
>http://www.abx.bmt.com.pl/rapa/box.wrl
>(please click on the box when loaded)

>--

>WebMajster oficjalnej strony VooVoo - http://www.voovoo.art.pl/



Mon, 23 Jul 2001 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. problems with string interpolation

2. Strange, very strange

3. Strange and serious problem on WinXP

4. Very strange problem in 5i

5. Strange problem with Linux/Vwnc30/Socketes

6. Strange Problem...

7. Strange Problem...

8. strange MVC problem

9. Request from a wizard: Solve this Strange and Deadly Build Problem

10. Strange problem with REALBasic 5.1 and window resizing

11. Strange problem in C5a - what I see is not what I get

 

 
Powered by phpBB® Forum Software