Anchor and Viewpoint does not work correctly in CosmoPlayer 2.1 
Author Message
 Anchor and Viewpoint does not work correctly in CosmoPlayer 2.1

Dear Sirs,

I have two worlds: 'Room1.wrl' and 'FileArk.wrl'. You start at Room1 and by
clicking at a door you are coming to FileArk. By clicking at the door again
you are coming back to Room1.

In Room1.wrl I have to Viewpoint: 'AtGate' where you start and 'OutDoor'
where you are supposed to come out from FileArk. So when you are in FileArk
I have written in FileArk.wrl:

            Anchor {
              description "To the Gateroom"
              url "Room1.wrl#OutDoor"
              children [
                Door1 { }
              ]
            }

... but I get a errormessage when I click at the door:

Can't open internet-site: .../Room1.wrl#OutDoor
Can't find the file

If I instead use:

url "Room1.wrl"

... the Anchor-node works, but I materialize at 'AtGate' not outside the
door. The:

url "Room1.wrl#OutDoor"

should be corect vrml syntax as I know. What could be wrong?

--------------------------------------------
Here come a bit more from 'Room1' and 'FileArk'

Room1:
.
.
.
#Stand on the 'Gaten'
  DEF OnGate Viewpoint {
   position 13.5 1.6 -4.5
   orientation 0 1 0 0.2618
   description "The Gate"
  }
#Out from door
  DEF OutDoor Viewpoint {
   position 22.5 1.6 -13.5
   orientation 0 1 0 1.570796
   description "The door"
  }
.
.
.

---------------------------------------------
FileArk:

.
.
.
# the door
        Transform {
          translation 5.7 0 -1
          rotation 0 1 0 -3.141593
          children [
            Anchor {
              description "To the Gateroom"
              url "Room1.wrl"
              children [
                Door1 { }
              ]
            }
          ]
        }
.
.
.
------------------------------------------------------

I use Internet Expolorer 4 with CosmoPlayer 2.1

you can look at my world at:
home8.swipnet.se/~w-80283/VRML/Room1.wrl

-----------
I have read the FAQ at Cosmosoftware:

Quote:
> My HTML link (or VRML Anchor) to a URL like "filename.wrl#ViewpointName"

doesn't take me to the specified Viewpoint!

Quote:
> This was a known bug in Cosmo Player 2.0, but it's fixed in Cosmo Player

2.1. (According to the VRML spec, this URL syntax is supposed to cause the
specified Viewpoint to be bound initially when the world loads, although
Cosmo Player 2.0 always binds the first Viewpoint found in the file
regardless of the Viewpoint name specified after the "#" character.)

Quote:
> Both Cosmo Player 2.0 and 2.1 do correctly handle Anchors like

"#ViewpointName" within the current file (you can use an Anchor like this to
take the user to a named Viewpoint within the current world.)
-----------
Your Sincerely

Henrik Teinelund
*****************************
Sm?rgatan 22
412 76 G?teborg
Sweden
Tel: +46(31)  - 40 65 22



Sun, 22 Jul 2001 03:00:00 GMT  
 Anchor and Viewpoint does not work correctly in CosmoPlayer 2.1

Quote:

> I have written in FileArk.wrl:

>             Anchor {
>               description "To the Gateroom"
>               url "Room1.wrl#OutDoor"
>               children [
>                 Door1 { }
>               ]
>             }

> ... but I get a errormessage when I click at the door:

> Can't open internet-site: .../Room1.wrl#OutDoor
> Can't find the file

Assuming it isn't the obvious (your file is on a Unix system
and you've got the case wrong on one of the characters in the
filename) try making the label all uppercase in both the
file where it's defined and in the URL.
--
Bob & Kelly Crispen

A polar bear is just a rectangular bear in a different coordinate system.


Sun, 22 Jul 2001 03:00:00 GMT  
 Anchor and Viewpoint does not work correctly in CosmoPlayer 2.1

Quote:

>            Anchor {
>              description "To the Gateroom"
>              url "Room1.wrl#OutDoor"
>              children [
>                Door1 { }
>              ]
>            }

>... but I get a errormessage when I click at the door:

Looks good to me. :)

Quote:
>Can't open internet-site: .../Room1.wrl#OutDoor
>Can't find the file

>I use Internet Expolorer 4 with CosmoPlayer 2.1

But this is the problem! No really, Internet Explorer 4 has problems with
the '#' in the url, it's a bug I have that problem during a project I did
about a year ago. I couldn't find a way to work it at that time, and still
haven't seen one. Netscape does work with the right way. The only thing I
could advise you right now: try the thing with Netscape. I haven't worked
with IE 5 to see if the problems where fixed.

Ciao,

--

Rbin van Buren

"Don't wake me while I'm working"



Mon, 23 Jul 2001 03:00:00 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. "No jump" Viewpoints and Cosmoplayer 2.1

2. sound clip not playing correctly viewpoint bind

3. tcl 8.2 regexp not doing non-greedy matching correctly

4. clarion 2.1 key files not working with clarion 4

5. inline node not working in cosmo 2.0/2.1????

6. cmdline.py not working in ActiveState Python 2.1

7. locale.setlocale not working anymore? python 2.1

8. -anchor not working?

9. Modal window not working correctly

10. Smalltalk Express : an image (v.exe) works correctly on WIN.NT4 but not on Win95

11. C4 APP does not work correctly under New XP

12. MSG attribute does not work correctly

 

 
Powered by phpBB® Forum Software