blaxxun Contact 4.3 Problem 
Author Message
 blaxxun Contact 4.3 Problem

Hello,

I'm using blaxxun contact 4.3 plugin and Netscape 4.6 on a Windows NT
PC.
I'm trying to render an IndexedFaceSet called pyramide.wrl:

#VRML V2.0 utf8
# pyramide.wrl
# selbstdefinierte 5-seitige Pyramide

Shape {
  geometry IndexedFaceSet {

    coord Coordinate {
      point [            # beteiligte Punkte
         0  3  0         # 0. Pyramidenpunkt (Spitze)
         0  0 -2         # 1. Pyramidenpunkt (Norden)
        -2  0  0         # 2. Pyramidenpunkt (Westen)
         0  0  2         # 3. Pyramidenpunkt (Sueden)
         2  0  0         # 4. Pyramidenpunkt (Osten )
      ]
    }

    coordIndex [         # Polygone gegen Uhrzeiger, Ende: -1
         4  3  2  1 -1   # 0. Face: Punkte 1 2 3 4 (Grundflaeche)
         0  1  2    -1   # 1. Face: Punkte 0 1 2   (Nordwesten)
         0  2  3    -1   # 2. Face: Punkte 0 2 3   (Suedwesten)
         0  3  4    -1   # 3. Face: Punkte 0 3 4   (Suedosten)
         0  4  1         # 4. Face: Punkte 0 4 1   (Nordosten)
    ]

    color{*filter*}ex FALSE
    color Color {
        color [          # pro Face eine Farbe benennen
          0 1 1          # 0. Face: Cyan
          1 0 0          # 1. Face: Rot
          1 1 0          # 2. Face: Gelb
          0 1 0          # 3. Face: Gruen
          0 0 1          # 4. Face: Blau
        ]
    }
  }

Quote:
}

Using color{*filter*}ex FALSE everything is fine but switching to TRUE
causes the plugin to render the whole pyramid in white with no lighting.
Adding a Material node like

appearance Appearance {
    material Material {}

Quote:
}

gives only lighted grey results.
Other renderers are doing the job well. Is this a known bug in contact
plugin or am I making a mistake?

Greetings

Olaf



Mon, 02 Sep 2002 03:00:00 GMT  
 blaxxun Contact 4.3 Problem

Hi Olaf,

this is neither a bug in Contact nor are you doing anything wrong:
There is a special rendering mode in Contact which causes the described
effect, namely Ramp mode in DirectX (the lowest available quality). If you
switch thr render mode to high quality (right click in the 3d window), this
effect will disappear.
In the OpenGL version you should never have this. As you state you use NT, I
guess that you installed the DirectX version of Contact, which as NT
sipports only DirectX3 would cause this effect. For NT the OpenGL version
should be used.
Bernd


Quote:
> Hello,

> I'm using blaxxun contact 4.3 plugin and Netscape 4.6 on a Windows NT
> PC.
> I'm trying to render an IndexedFaceSet called pyramide.wrl:

> #VRML V2.0 utf8
> # pyramide.wrl
> # selbstdefinierte 5-seitige Pyramide

> Shape {
>   geometry IndexedFaceSet {

>     coord Coordinate {
>       point [            # beteiligte Punkte
>          0  3  0         # 0. Pyramidenpunkt (Spitze)
>          0  0 -2         # 1. Pyramidenpunkt (Norden)
>         -2  0  0         # 2. Pyramidenpunkt (Westen)
>          0  0  2         # 3. Pyramidenpunkt (Sueden)
>          2  0  0         # 4. Pyramidenpunkt (Osten )
>       ]
>     }

>     coordIndex [         # Polygone gegen Uhrzeiger, Ende: -1
>          4  3  2  1 -1   # 0. Face: Punkte 1 2 3 4 (Grundflaeche)
>          0  1  2    -1   # 1. Face: Punkte 0 1 2   (Nordwesten)
>          0  2  3    -1   # 2. Face: Punkte 0 2 3   (Suedwesten)
>          0  3  4    -1   # 3. Face: Punkte 0 3 4   (Suedosten)
>          0  4  1         # 4. Face: Punkte 0 4 1   (Nordosten)
>     ]

>     color{*filter*}ex FALSE
>     color Color {
>         color [          # pro Face eine Farbe benennen
>           0 1 1          # 0. Face: Cyan
>           1 0 0          # 1. Face: Rot
>           1 1 0          # 2. Face: Gelb
>           0 1 0          # 3. Face: Gruen
>           0 0 1          # 4. Face: Blau
>         ]
>     }
>   }
> }

> Using color{*filter*}ex FALSE everything is fine but switching to TRUE
> causes the plugin to render the whole pyramid in white with no lighting.
> Adding a Material node like

> appearance Appearance {
>     material Material {}
> }

> gives only lighted grey results.
> Other renderers are doing the job well. Is this a known bug in contact
> plugin or am I making a mistake?

> Greetings

> Olaf



Tue, 03 Sep 2002 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Blaxxun Contact: BSPTree Problem

2. blaxxun Contact 5.1 extrusion lighting problem

3. Sound bug in [blaxxun Contact 4.2] ?

4. blaxxun eai contact with browser in another frame

5. Blaxxun Contact Examine mode Center of rotation/HUD conflict

6. drawOp: zbias etc ... (Blaxxun Contact)

7. Orthographic/Parallel Projection with Layer2D in Blaxxun Contact

8. IE error with Blaxxun Contact and Morpheus 2.0

9. Opening / Clearing (Blaxxun Contact) Console Automatically

10. questions about Blaxxun Contact

11. PROTOS and sfimage /blaxxun contact

12. blaxxun Contact mode "SLIDE"

 

 
Powered by phpBB® Forum Software