Browser.getBrowser not working 
Author Message
 Browser.getBrowser not working

Hi,

Easy question, but I just can't get it to work: Browser.getBrowser(this)
keeps generating exceptions. I've tried putting it in a loop, like this:

  public void start() {
    boolean cosmoLoaded = false;

    while (!(cosmoLoaded)) {
      try {
        browser = Browser.getBrowser(this);
        cosmoLoaded = true;
      catch (Exception e) {
        System.out.println("OK, let's try again.");
      }
    }
    (...)
  }

Still, it doesn't work. Any ideas? I'm now using Netscape 4.05 and
CosmoPlayer 1.1 on IRIX. It seemed to work fine with Netscape 3.0.
Here's my CLASSPATH (in case it is of any use):

/usr/CosmoPlayer/classes:/var/netscape/communicator/java40.jar

Any hints are greatly appreciated.

Best regards,

Wilco
--
= Wilco Vertegaal                        = "A kingdom! A kingdom!     =

= homepage: http://www.*-*-*.com/ ~vertegaa =  -Richard III, afterwards  =



Fri, 16 Mar 2001 03:00:00 GMT  
 Browser.getBrowser not working
Hi,

I printed the exception that is generated by the Browser.getBrower call.
Here it is:

netscape.javascript.JSException: unable to reflect embed with index 0 -
not loaded yet?
  at vrml.external.Browser.getBrowser(Compiled Code)
* at vrml.external.Browser.getBrowser(Compiled Code)
  at TicTacToeEAI.start(Compiled Code)
  at netscape.applet.DerivedAppletFrame.run(Compiled Code)
  at java.lang.Thread.run(Thread.java)

Does this help? I hope so, because I'm quite stuck right now.

Best regards,

Wilco
--
= Wilco Vertegaal                        = "A kingdom! A kingdom!     =

= homepage: http://stad.dsl.nl/~vertegaa =  -Richard III, afterwards  =



Fri, 16 Mar 2001 03:00:00 GMT  
 Browser.getBrowser not working
Hi Wilco,

Welcome to the dodgy world of vrml on Irix :(  I'm using a similarly
configured system, and I need a "sacrificial" VRML world and applet to
load and fail before I attempt to load the real world.

I've got a simple page with a 1x1 pixel VRML world and an applet with no
user interface.  The VRML world has a single node, and the applet
attempts to get a node reference to it.  I expect this to fail, normally
with the same error messages you're seeing.

On this same HTML page, I have a link to my real world which
automatically jumps after five seconds.  Once the instantiation of the
EAI has failed on this simple world, the proper world loads fine.  Don't
ask my why, or why shift-reloading your main world will never work
either.

Be warned that _nothing_ will make Netscape 4.06 for Irix work with the
EAI, so you'll need to stick with 4.05 until the beta of CP2.1 is
released.

Hope this helps,

Gil Carter.                              

+--------------------------------------------------------------------+
| 3D Visualisation Programmer,          Telephone: +61 7 3212 4720   |
| CSIRO,                                Facsimile: +61 7 3212 4455   |
| 2643 Moggill Rd.,                     Postal: P.O. Box 883,        |
| Pinjarra Hills, QLD 4069.             Kenmore, QLD 4069, Australia.|
+--------------------------------------------------------------------+
| "Don't be afraid to go out on a limb - that's where the fruit is"  |
|                                             H. Samuel Johnson      |
+--------------------------------------------------------------------+



Sat, 17 Mar 2001 03:00:00 GMT  
 
 [ 5 post ] 

 Relevant Pages 

1. Browser::getBrowser: Plugin pointer not available.

2. (Browser.getBrowser)Problem.

3. Browser.getBrowser(this)

4. pb: Browser.getBrowser(this) and Class name?

5. Browser.getBrowser(Applet)

6. Browser.getBrowser() always failed when using Netscape

7. pb with EAI, getBrowser() doesn't work

8. Small Announce: tar tool and directory browser (not file browser)

9. REALdatabase not null and primary key not working

10. Does not work with TPS but works with DBF

11. NOT Allow Inserts not working

12. 5.2 Network application works with 95, does not work with 98

 

 
Powered by phpBB® Forum Software