Does anyone know how to run java2 and VRML? 
Author Message
 Does anyone know how to run java2 and VRML?

I am using the Cortona vrml player and for the java classes, I have to
compile as 1.1. Has anyone figured out why this is the case, and how
to overcome this? There are alot of packages out there, as well as
functions that are only supported in java2, like ArrayList!

Anyone know this!

Thanks,
Edmond



Sun, 03 Oct 2004 15:33:30 GMT  
 Does anyone know how to run java2 and VRML?
You have to compile as 1.1 because the Cortona EAI is dependent on the MS
Java VM which is at version 1.1.4. To be spec compliant vrml plugins only
have to support Java 1.1 so you can only assume the viewing browser plugin
will support Java 1.1.

I am not aware of any commercially available VRML plugin supporting EAI that
will work with the sun jre plugins.

Most people wanting to use java2 + vrml do so because they want to use
Swing, if this is the case then you could either use JDK 1.1.8 which
supports an early release of Swing or to use other third-party java1.1
compliant gui classes (take a look at www.imint.com for example).

Here is an example of a 1.1 compliant applet tree panel interacting with a
vrml scene vai eai:

http://www.jpitten.btinternet.co.uk/ws/TestPage.html

If you're interested in the applet source let me know.

Jeremy


Quote:
> I am using the Cortona VRML player and for the java classes, I have to
> compile as 1.1. Has anyone figured out why this is the case, and how
> to overcome this? There are alot of packages out there, as well as
> functions that are only supported in java2, like ArrayList!

> Anyone know this!

> Thanks,
> Edmond



Sun, 03 Oct 2004 22:45:08 GMT  
 Does anyone know how to run java2 and VRML?
Hi Jeremy,

Just a little discordance... as far as I know M$ JVM is version 1.1.6.
By the way, does any body knows what version is the last M$ Java Virtual
Machine?

I'm really interested in nice look personalized applets... do you know any
tool like SkinLF (http://www.l2fprod.com) but 1.1 compliant?

Thanks in advance,

    Marc Bria.



Quote:
> You have to compile as 1.1 because the Cortona EAI is dependent on the MS
> Java VM which is at version 1.1.4. To be spec compliant vrml plugins only
> have to support Java 1.1 so you can only assume the viewing browser plugin
> will support Java 1.1.

> I am not aware of any commercially available VRML plugin supporting EAI
that
> will work with the sun jre plugins.

> Most people wanting to use java2 + vrml do so because they want to use
> Swing, if this is the case then you could either use JDK 1.1.8 which
> supports an early release of Swing or to use other third-party java1.1
> compliant gui classes (take a look at www.imint.com for example).

> Here is an example of a 1.1 compliant applet tree panel interacting with a
> vrml scene vai eai:

> http://www.jpitten.btinternet.co.uk/ws/TestPage.html

> If you're interested in the applet source let me know.

> Jeremy



> > I am using the Cortona VRML player and for the java classes, I have to
> > compile as 1.1. Has anyone figured out why this is the case, and how
> > to overcome this? There are alot of packages out there, as well as
> > functions that are only supported in java2, like ArrayList!

> > Anyone know this!

> > Thanks,
> > Edmond



Mon, 04 Oct 2004 05:25:01 GMT  
 Does anyone know how to run java2 and VRML?

  For complex 3d animation where the controls
and behaviors are relatively complex ( vs.
just high polygon counts ) using Java without
the plug-in will generally be easier / better
than the old way of using browser + plug-in +
VRML EAI.

__ Free source code __ for a modern, complex,
3d networked solution is available ( see below )
that combines VRML with Java.

  VRML can be animated with plug-in or without,
  with Java, or without, and with the plug-in
  combined with Java ( VRML EAI ) to get the
  power of the plug-in combined with the
  powerfull programming capailities of Java.

  I've done all of the above.

I've used Shout3d to animate Avatars on
the web as you can see ( and interact with ):

Avatars with Gestures, Playing Chess & Darts
--------------------------------------------
http://www.frontiernet.net/~imaging/H-Anim_Avatars.html
http://www.frontiernet.net/~imaging/shout3d/models/
http://www.frontiernet.net/~imaging/shout3d/models/H-Anim/nancy_H-Ani...

"Nancy" is H-Anim Avatar varient with Gestures
( Walk, Run, Jump, Stand ). Click or double click
on "Nancy" then click on the buttons or colored bar
to trigger the animations, after it has fully loaded.

  VRML EAI has been done successfully with
Cosmo and it's newer incarnation, the Pivoron plug-in,
a more popular / succesfull combination than using
ParallelGraphics Cortona.

  VRML EAI FAQ & Demo ( VRML + plug-in + Java )
  ---------------------------------------------
  http://www.frontiernet.net/~imaging/eaifaq.html
  http://www.frontiernet.net/~imaging/HAnimPoser.html
  ( requires Cosmo or Contact plug-in )

  Distributed Interactive Simulation DIS-Java-VRML Working Group
  --------------------------------------------------------------
  http://www.web3d.org/WorkingGroups/vrtp/dis-java-vrml/
  http://www.web3d.org/WorkingGroups/vrtp/dis-java-vrml/examples.html

| Summary of DIS, Java and VRML:
|
| The IEEE Distributed Interactive Simulation (DIS)
| Protocol is used to communicate state information
| (such as position, orientation, velocities and
| accelerations) among multiple entities participating
| in a shared network environment.
|
| Java is a portable networked programming language
| that can interoperate on any computer that includes
| a Web three-dimensional (3D) graphics across
| the Internet, and can be used to compose
| sophisticated 3D virtual environments.
|
| The DIS-Java-VRML Working Group is developing
| __ a free software library, __ written in Java
| and interoperable with both DIS and VRML.
|
  http://web.nps.navy.mil/~brutzman/vrtp/dis-java-vrml/ReleaseNotes.txt

|
| Tested satisfactorily using
|
| Nexternet's Pivoron browser   http://www.nexternet.com
|
|    Netscape 4.79 (but not Netscape 6.2 due in installation problems).
|    Significant performance improvement shown on all scenes. :)
|    A few new browser bugs are now being diagnosed and reported.
|    Thanks to the Pivoron team for a great job!
|
| [ Don Brutzman, Web3d.org Board member, U.S. Navy ( N.P.S. ) ]
| [ posted to www-vrml list  Mon Apr 15 2002 ]
| [ http://web.nps.navy.mil/~brutzman ]
|
  http://www.web3d.org/www-vrml/hypermail/2002/04/0027.html

  Don's ( or the Navy's ) Source code is available for _ free _.
  ----------------------- ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

[ in reply to : ]
-----------------
 >

Quote:
> I am using the Cortona VRML player and for the

 > java classes, I have to compile as 1.1.
 >
Quote:
> Has anyone figured out why this is the case, and how
> to overcome this?

> There are alot of packages out there, as well as
> functions that are only supported in java2, like ArrayList!

> Anyone know this!

> Thanks,
> Edmond

|
  edmondme wrote to comp.lang.vrml on 4/17/2002
|
http://groups.google.com/groups?dq=ccomp.lang.vrml&hl=en&threadm=3cbd...

  Dump the Cortona plug-in and Microsoft's old,
non-compliant, non-supported, orphaned version of Java.

  The Parallel Graphics people seem to take pride
in making their VRML viewer fail with Mozilla
Java, and Linux: anything what the products of
the Monopolist which has been found guilty of
using it's desktop Monopoply to destroy products
and standards that it does not control.

  VRML should be portable, and with Java it is.

| DIS-Java-VRML Working Group ...
|
| Software Download and Installation
|
|
| Ensure you have a Java-compliant VRML 97 browser
| installed in Netscape.
|
|    * We currently support CosmoPlayer.
|      -------------------- ===========
|
|      Download CosmoPlayer CosmoPlayer 2.1.1
| plugin for Windows/Irix Netscape or Internet Explorer.
|
|      Download CosmoPlayer Karmanaut mirror site:
| CosmoPlayer 2.1.1 plugin for Netscape or Internet Explorer.
|
http://www.web3d.org/WorkingGroups/vrtp/dis-java-vrml/download.html

Games with Shout3d:

Tank Combat Game, 3d Shooter with Shout3d
-----------------------------------------------
| "Tank Game is a classic first-person 3D shooter
| written in pure Java. Developed using Shout3D 1.03,
| Tank Game begins to demonstrate the power of
| pluginless interactive 3D graphics on the Internet."
|
http://www.ismarvr.cz/g2/

  The Virtual Reality Modeling Language (VRML) and Java
  -----------------------------------------------------
  http://web.nps.navy.mil/~brutzman/vrml/vrmljava.pdf

VRML EAI is mostly the OLD - WAY of doing things.

  The VRML EAI books are out of print, that should be a hint.

Do 3d Portably, the modern way:
-------------------------------

High Performance Web Animation of VRML with Java3d
----------------------------------------------------
  http://www.frontiernet.net/~imaging/java3d_and_vrml.html
  http://www.frontiernet.net/~imaging/games_with_java3d.html

  Java3d interest: Universities & Research Teams use this:
  -------------------------------------------------------
  http://archives.java.sun.com/cgi-bin/wa?A1=ind0204&L=java3d-interest

  -- Paul, Java Developer & Web Animator.
  ----------------------------------------
"Imaging the Imagined: Modeling with Math & Keyboard"



Tue, 05 Oct 2004 01:49:13 GMT  
 Does anyone know how to run java2 and VRML?

Quote:
>  The Parallel Graphics people seem to take pride
> in making their VRML viewer fail with Mozilla
> Java, and Linux: anything what the products of
> the Monopolist which has been found guilty of
> using it's desktop Monopoply to destroy products
> and standards that it does not control.

???

Parallel Graphics deliver products also for netscape broswer, and for the
MAC, MACOS X, 2D java and AFAIK compaq pocket computer (OS???) platforms.

http://www.parallelgraphics.com/products/

This do not sound like only supporting products of the monopolist.

And please remind: there are not much good VRML viewers on the MAC
platform, cosmoplayer only had a rather unstable beta for the MAC,
twirl seams to be frozen since 2 years, and xj3d can not run on
the MAC, cause there is no java3D on the MAC 8-(

Quote:
>  VRML should be portable, and with Java it is.
> | DIS-Java-VRML Working Group ...
> |
> | Software Download and Installation
> |
> |
> | Ensure you have a Java-compliant VRML 97 browser
> | installed in Netscape.
> |
> |    * We currently support CosmoPlayer.
> |      -------------------- ===========
> |
> |      Download CosmoPlayer CosmoPlayer 2.1.1
> | plugin for Windows/Irix Netscape or Internet Explorer.
> |
> |      Download CosmoPlayer Karmanaut mirror site:
> | CosmoPlayer 2.1.1 plugin for Netscape or Internet Explorer.
> |
> http://www.web3d.org/WorkingGroups/vrtp/dis-java-vrml/download.html
> Games with Shout3d:
> Tank Combat Game, 3d Shooter with Shout3d
> -----------------------------------------------
> | "Tank Game is a classic first-person 3D shooter
> | written in pure Java. Developed using Shout3D 1.03,
> | Tank Game begins to demonstrate the power of
> | pluginless interactive 3D graphics on the Internet."
> |
> http://www.ismarvr.cz/g2/
>  The Virtual Reality Modeling Language (VRML) and Java
>  -----------------------------------------------------
>  http://web.nps.navy.mil/~brutzman/vrml/vrmljava.pdf
> VRML EAI is mostly the OLD - WAY of doing things.
>  The VRML EAI books are out of print, that should be a hint.
> Do 3d Portably, the modern way:
> -------------------------------
> High Performance Web Animation of VRML with Java3d
> ----------------------------------------------------
>  http://www.frontiernet.net/~imaging/java3d_and_vrml.html
>  http://www.frontiernet.net/~imaging/games_with_java3d.html
>  Java3d interest: Universities & Research Teams use this:
>  -------------------------------------------------------
>  http://archives.java.sun.com/cgi-bin/wa?A1=ind0204&L=java3d-interest
>  -- Paul, Java Developer & Web Animator.
>  ----------------------------------------
> "Imaging the Imagined: Modeling with Math & Keyboard"

--
Gabeln nicht m?glich: zu viele Prozesse
       (deutsche Fehlermeldung von SCO OpenServer 5.0.4, Stichwort: fork)


Tue, 05 Oct 2004 03:08:54 GMT  
 Does anyone know how to run java2 and VRML?

 >>

Quote:
>> The Parallel Graphics people seem to take pride
>>in making their VRML viewer fail with Mozilla
>>Java, and Linux: anything what the products of
>>the Monopolist which has been found guilty of
>>using it's desktop Monopoply to destroy products
>>and standards that it does not control.

> ???

> Parallel Graphics deliver products also for netscape broswer, and for the
> MAC, MACOS X, 2D java and AFAIK compaq pocket computer (OS???) platforms.
>  ...

> This do not sound like only supporting products of the monopolist.

> And please remind: there are not much good VRML viewers on the MAC
> platform, cosmoplayer only had a rather unstable beta for the MAC,
> twirl seams to be frozen since 2 years, and xj3d can not run on
> the MAC, cause there is no java3D on the MAC 8-(

>> VRML should be portable, and with Java it is.

  Er, the Compaq Pocket PC runs the Monopolist's OS.

  Microsoft Internet Explorer and Microsoft Office
run on the Mac too, so Microsoft could control
both the browser and office file formats and
Microsoft could, and did, threaten Apple when
it pushed their Quicktime Streaming Media format.

  The original poster was having trouble combining
the Parallel Graphics plugin with Java, which
Microsoft is not shipping with their current OS,
so that is a dead end.

  If you want portable VRML: avoid the combination
of Parallel Graphics and Java, which is what the
original poster was doing.

  Please note my prior post included links to
what I think is the largest current VRML EAI
project, it's a project led by a Web3d.org
board Member ( Brutzman ) and they use Cosmo
and Nexternet's Pivoron: they had tried
ParallelGraphics but it repeatedly failed
and ParallelGraphics made repeated promises
to support the VRML EAI features they needed,
but that never around to being as far as I know.

  Parallel Graphics supports multiple 'solutions'
that work "only with Microsoft Internet Explorer"
which is not what 3d web animation is about;
they support ActiveX extensions which are non-portable
virsus magnets that many people ( wisely ) avoid.

  I'm running Linux: I can animate VRML with Java
that is portable across Windows, Linux, Macintosh,
Solaris, Silicon Graphics / SGI etc.

  The plug-ins don't do that.

  Many computer graphics movies ( Shrek et al )
are rendered on Linux, Linux and other Unixes
are by and for developers.

  Serious animators are being drawn to Linux
and the other Unixes: the trend cannot be denied.

New Candian CAVE, the Worlds Newest & Best with Java3d
------------------------------------------------------
| A unique feature of the center ... is the ability
| to create 3D models of biological systems
| (e.g., genomes, organs, cancer cells) using a
| Java 3D API-enabled Sun FireTM 6800 server
| with a CAVE (CAVE Automatic Virtual Environment)
| walk-in virtual room often likened to Star Trek's Holodeck.
|
| In addition to the 20 CPU Sun Fire 6800 server
| running on the Solaris 8 Operating Environment
| equipped with 20 Gigabytes of main memory,
| the COE hosts five terabytes of Sun StorEdge
| T3 RAID 5 disk arrays
|
http://www.supercomputingonline.com/article.php?sid=1609

| Canadian scientists have opened a powerful
| computing lab ... The $3.7 million
| University of Calgary facility is
| a step ahead of the handful of other
| virtual reality labs used in such research
| because users for the first time can build
| models on their own computers, rather than be
| tied up for days or weeks programming at the
| site, officials said.
|
| Scientists, wearing 3D glasses in the
| 10 foot by 10 foot "cave," get a 270-degree,
| larger-than-life projection of the smallest
| parts of our biological makeup, to the point
| of being able to stand inside a strand of DNA.
|
http://archives.java.sun.com/cgi-bin/wa?A2=ind0203&L=java3d-interest&...
http://story.news.yahoo.com/news?tmpl=story&cid=581&u=/nm/20020301/tc...

  Just because Windows comes installed doesn't
mean you have to live with it: Upgrade to Linux.

  If you're doing serious 3d stuff, you need
a modern Object-Oriented Programs System.

  Move beyond the Desktop, with Java.

  High Performance Web Animation of VRML with Java3d
  ----------------------------------------------------
  http://www.frontiernet.net/~imaging/java3d_and_vrml.html
  http://www.frontiernet.net/~imaging/games_with_java3d.html

  Java3d interest: Universities & Research Teams use this:
  -------------------------------------------------------
  http://archives.java.sun.com/cgi-bin/wa?A1=ind0204&L=java3d-interest

  -- Paul, Java Developer & Web Animator.
  ----------------------------------------
  "Imaging the Imagined: Modeling with Math & Keyboard"



Tue, 05 Oct 2004 07:10:09 GMT  
 Does anyone know how to run java2 and VRML?
Ol` Flavin is a Java nut good for him but it gets boring listening to
the same humdrum attacks on Better ways of showing vrml.
Parallelgraphics ROCKS!!


Thu, 07 Oct 2004 05:06:28 GMT  
 Does anyone know how to run java2 and VRML?
The reason I wanted to use the java 2 stuff, was because all the array
stuff is in java2 and I am having problems with co-existence of
jdbc-odbc bridge and havent gotten the jdbc stuff to work with excel!

Edmond

Quote:

> Hi Jeremy,

> Just a little discordance... as far as I know M$ JVM is version 1.1.6.
> By the way, does any body knows what version is the last M$ Java Virtual
> Machine?

> I'm really interested in nice look personalized applets... do you know any
> tool like SkinLF (http://www.l2fprod.com) but 1.1 compliant?

> Thanks in advance,

>     Marc Bria.



> > You have to compile as 1.1 because the Cortona EAI is dependent on the MS
> > Java VM which is at version 1.1.4. To be spec compliant vrml plugins only
> > have to support Java 1.1 so you can only assume the viewing browser plugin
> > will support Java 1.1.

> > I am not aware of any commercially available VRML plugin supporting EAI
>  that
> > will work with the sun jre plugins.

> > Most people wanting to use java2 + vrml do so because they want to use
> > Swing, if this is the case then you could either use JDK 1.1.8 which
> > supports an early release of Swing or to use other third-party java1.1
> > compliant gui classes (take a look at www.imint.com for example).

> > Here is an example of a 1.1 compliant applet tree panel interacting with a
> > vrml scene vai eai:

> > http://www.jpitten.btinternet.co.uk/ws/TestPage.html

> > If you're interested in the applet source let me know.

> > Jeremy



> > > I am using the Cortona VRML player and for the java classes, I have to
> > > compile as 1.1. Has anyone figured out why this is the case, and how
> > > to overcome this? There are alot of packages out there, as well as
> > > functions that are only supported in java2, like ArrayList!

> > > Anyone know this!

> > > Thanks,
> > > Edmond



Wed, 27 Oct 2004 13:04:17 GMT  
 
 [ 10 post ] 

 Relevant Pages 

1. Anyone doing VRML on SGI's ?

2. MicroFocus running on Windows NT - Anyone doing this?

3. anyone know if Versant will run under Windows95?

4. lighting Ive done / do you know other (complex) lighting examples

5. how to know if whole file is done loading

6. Testing, I know I keep doing it but I'm tesating :-)

7. Anyone knows how to run "package require Img" when not running x-windows / windows ?

8. Anyone doing anything with NNTP in Dolphin?

9. Anyone done anything about comparing methods ...

10. Anyone done OPC with any of the Smalltalks?

11. RB2.0 and ODBC - Anyone done it?

12. DYMO Labelwriter - Anyone done any work with SDK

 

 
Powered by phpBB® Forum Software