Java Plug-in 1.2 and EAI 
Author Message
 Java Plug-in 1.2 and EAI

Hi,

I have tryed to use Java Plug-in 1.2 with EAI with NS4.5 and IE4.
In both cases I have had the same error message:

Tiny3D.init()...
Tiny3D.start()...
java.lang.UnsatisfiedLinkError: getBrowserType
 at vrml.external.Browser.getBrowser(Compiled Code)
 at PerceptionPanelLRF.start(Compiled Code)
 at sun.applet.AppletPanel.run(Compiled Code)
 at java.lang.Thread.run(Thread.java:479)

The Java applet is not able to get the browser. I've used Cosmoplayer as
vrml Plug-in and it starts normally without problems.

I think that probably NS and IE cannot find the native code for
executing the EAI. I've tryed to copy Cosmoplayer files in the Java
plug-in directory without result.

What can I do?

Thanks in advance for any suggestions!!!   :)))

Emanuele

--
======================================================================
Emanuele Bovisio                                             tel:
+39-0332-785 195
Joint Research Centre                                      fax:
+39-0332-789 185
TP 270 - via E. Fermi                                      e-mail:

21020 Ispra (VA) - ITALY
======================================================================



Fri, 06 Jul 2001 03:00:00 GMT  
 Java Plug-in 1.2 and EAI
I have seen this error a few times when I (mistakenly) build an
application/Applet with one version of JDK and then try to run it using a
different version of the JVM.

For example, if you compile all your classes using the standard JDK1.1.6
compiler and then try to run it using the Solaris specific optimised version
of the Java compiler (which uses native threads instead of green threads
etc.) then you get this kind of "UnsatisfiedLinkError".

I have also seen it when trying to run classes that were built with JDK1.1.6
but running them in the JDK1.2 JVM.

Hope this helps,

Mike

Quote:

> Hi,

> I have tryed to use Java Plug-in 1.2 with EAI with NS4.5 and IE4.
> In both cases I have had the same error message:

> Tiny3D.init()...
> Tiny3D.start()...
> java.lang.UnsatisfiedLinkError: getBrowserType
>  at vrml.external.Browser.getBrowser(Compiled Code)
>  at PerceptionPanelLRF.start(Compiled Code)
>  at sun.applet.AppletPanel.run(Compiled Code)
>  at java.lang.Thread.run(Thread.java:479)

> The Java applet is not able to get the browser. I've used Cosmoplayer as
> VRML Plug-in and it starts normally without problems.

> I think that probably NS and IE cannot find the native code for
> executing the EAI. I've tryed to copy Cosmoplayer files in the Java
> plug-in directory without result.

> What can I do?

> Thanks in advance for any suggestions!!!   :)))

> Emanuele

> --
> ======================================================================
> Emanuele Bovisio                                             tel:
> +39-0332-785 195
> Joint Research Centre                                      fax:
> +39-0332-789 185
> TP 270 - via E. Fermi                                      e-mail:

> 21020 Ispra (VA) - ITALY
> ======================================================================

--
Mike Haberfield,                    Tel: 0171 236 2850
Tamesis Limited,                    Fax: 0171 236 2677

London EC4R 3TE


Fri, 06 Jul 2001 03:00:00 GMT  
 Java Plug-in 1.2 and EAI

: I have seen this error a few times when I (mistakenly) build an
: application/Applet with one version of JDK and then try to run it using a
: different version of the JVM.

: For example, if you compile all your classes using the standard JDK1.1.6
: compiler and then try to run it using the Solaris specific optimised version
: of the Java compiler (which uses native threads instead of green threads
: etc.) then you get this kind of "UnsatisfiedLinkError".

: I have also seen it when trying to run classes that were built with JDK1.1.6
: but running them in the JDK1.2 JVM.

: Hope this helps,

: Mike

I don't think so.
Java plugin currently lacks support for LiveConnect on which EAI
implementation relies. It is because of the deficiency of required
functionalities in plug-in API.

Do-Hyung



Fri, 06 Jul 2001 03:00:00 GMT  
 Java Plug-in 1.2 and EAI
check your classpath in autoexec.bat. (I guess...)

ex) SET CLASSPATH = c:\cosmosoftware\cosmoplayer\npcosmo21.zip;

~~~~~~~~~
(sorry, I can't write english well ^^;)


??o?????...

Quote:
>Hi,

>I have tryed to use Java Plug-in 1.2 with EAI with NS4.5 and IE4.
>In both cases I have had the same error message:

>Tiny3D.init()...
>Tiny3D.start()...
>java.lang.UnsatisfiedLinkError: getBrowserType
> at vrml.external.Browser.getBrowser(Compiled Code)
> at PerceptionPanelLRF.start(Compiled Code)
> at sun.applet.AppletPanel.run(Compiled Code)
> at java.lang.Thread.run(Thread.java:479)

>The Java applet is not able to get the browser. I've used Cosmoplayer as
>VRML Plug-in and it starts normally without problems.

>I think that probably NS and IE cannot find the native code for
>executing the EAI. I've tryed to copy Cosmoplayer files in the Java
>plug-in directory without result.

>What can I do?

>Thanks in advance for any suggestions!!!   :)))

>Emanuele

>--
>======================================================================
>Emanuele Bovisio                                             tel:
>+39-0332-785 195
>Joint Research Centre                                      fax:
>+39-0332-789 185
>TP 270 - via E. Fermi                                      e-mail:

>21020 Ispra (VA) - ITALY
>======================================================================



Sat, 07 Jul 2001 03:00:00 GMT  
 Java Plug-in 1.2 and EAI
Hello, I've got a engeneering project about VRML and how to programm a
3D animation using a VRML file ( which contain all the elements about a
human body) and an applet JAVA for the animation
In fact have you got any inforamtion about this ?
ie for instance a programm in JAVA which animate a body programmed in
VRML


Fri, 13 Jul 2001 03:00:00 GMT  
 
 [ 5 post ] 

 Relevant Pages 

1. Java Plugin 1.2 (Java 1.2)

2. Java 1.2 plugin and EAI

3. Java plug-in 1.2 and vrml

4. Java Plug-in 1.2

5. Using EAI with JDK 1.2 & JDK 1.2 plugin

6. EAI and the Java 2 plugin

7. Java Plugin 1.1.2 & EAI

8. Java 2 Plug-in and EAI

9. Java Plug-In and EAI?

10. Java Plugin & EAI

11. Java Plug-In and the EAI?

12. EAI and Java 1.3 Plug-In?

 

 
Powered by phpBB® Forum Software