shading problem 
Author Message
 shading problem

I'm just starting out and would appreciate any help.
Some of my objects do not appear shaded.  I've
isolated the problem but am not sure of a solution.
The below code demonstrates the problem.  As is,
the shading of the sphere looks correct, but if I switch
the order of the two groups (place the star before the
sphere) the sphere then looses all shading.  I'm sure
this thre is a simple answer and would appreciate
someone letting me know the answer.
Thanks,
Rob

#VRML V2.0 utf8
Group {children[
        # Define a Ball
            DEF Ball
            Shape {appearance Appearance{
                    material Material{
                     diffuseColor 1.0 1.0 0.0}}
              geometry Sphere {
                     radius 1.5}}
        ]},

Group {children[
         Transform{translation -5 5 -2
         children[
    # A star defined by points
    Shape {
  appearance Appearance {
     material Material {
   emissiveColor 1.0 1.0 1.0}}
  geometry IndexedLineSet {
          coord Coordinate {
   point [
   # Coordinates of the star
     0.0  0.0  0.0,
    -0.25 1.0  0.0,
     0.5  1.5  0.0,
     1.25 1.0  0.0,
     1.0  0.0  0.0]}
     coordIndex [
   0, 2, 4, 1, 3, 0]}}]}
]},



Tue, 10 Dec 2002 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Texture-mapped shaded polygon problem

2. problem with polygon shading, pls help!!!

3. Title bar shading

4. Looking for Shading tips

5. Drop shade

6. LOGO-L> Strange shade

7. LOGO-L> shading

8. LOGO-L> Color Shades

9. how do I shade both faces of an indexed faceset

10. is shading possible ?

11. Smooth shading

12. smooth shading?

 

 
Powered by phpBB® Forum Software