LOD problems 
Author Message
 LOD problems

More help needed, I'm afraid.

I've been writing a temple (doesn't everyone?). In vrml 1, because
a) that's all a friend of mine can see, he says
b) that's all I've got a viewer for in work, under Win3.1

It's got the basic main walls, a "statue" or two, and some rooms down the
sides. This is where I tried to get clever (well, by my standards): I
decided to put each group of rooms inside an LOD. When you're close up,
you get interior walls, doorways, fireplaces, and so on. When you're a
long way away, just the basic cuboid is plenty, especially as this is
going in-line in a much larger city (I hope).  LOD time, obviously.

In VR Scout (my VRML1 viewer) this looks fine. But when I go into Cosmo,
it all comes apart. I have one range: 100. When I'm > 100 away, I get the
boxes as planned. When I'm < 100, I get a blank space, which looks
remarkably silly.

Have I got the LOD wrong, is Cosmo being fussy, or what? It was working
fine a while back, before I put the LOD around it. And VRScout, which
usually reports any sillies, has no problems with it.

The temple lives at
http://www.*-*-*.com/ ~janewill/vrml/orlanth.wrl

BTW, it isn't purely my invention, the floorplan is from an RPG supplement
called "Strangers in Prax".  This in no way tries to infringe their
copyright, etc. etc.


http://www.*-*-*.com/ ~janewill/



Fri, 24 Dec 1999 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. LOD problem

2. LOD problem...help!

3. Problem with LOD within PROTO

4. LOD, 3DSMAX, and variable visibility limit problem

5. Downloading problem with LOD

6. Alternative formulation of LOD (Re: Law of Demeter)

7. LOD overhead

8. Dynamic LOD filtering?

9. add children to lod

10. lod-inlines loading to early

11. LOD that changes level by a ROUTE?

12. LOD and the elevation grid???

 

 
Powered by phpBB® Forum Software