type library 
Author Message
 type library

I have a type library created in C++ (.tlb).  this library has been loaded
into my project as a reference many times with no problems.  now, it simply
won't work.  i get an error "unable to load type library".  what can cause
this?  why did it work for so long and suddenly it is giving me a hard time?

jeff



Sat, 23 Apr 2005 03:57:27 GMT  
 type library
Well, err., let me see, did you just download a service pack for windows
2000 or XP?


Quote:
> I have a type library created in C++ (.tlb).  this library has been loaded
> into my project as a reference many times with no problems.  now, it
simply
> won't work.  i get an error "unable to load type library".  what can cause
> this?  why did it work for so long and suddenly it is giving me a hard
time?

> jeff



Sat, 23 Apr 2005 04:13:07 GMT  
 type library
no, haven't done that in a while...

jeff



Quote:
> Well, err., let me see, did you just download a service pack for windows
> 2000 or XP?



> > I have a type library created in C++ (.tlb).  this library has been
loaded
> > into my project as a reference many times with no problems.  now, it
> simply
> > won't work.  i get an error "unable to load type library".  what can
cause
> > this?  why did it work for so long and suddenly it is giving me a hard
> time?

> > jeff



Sat, 23 Apr 2005 04:25:29 GMT  
 type library
j h, what changed about the tlb?  Did you recompile it?  Did you change it's
location?  Try running tlbimp on it again or deleting it and readding it to
your project references.

--
Greg Ewing [MVP]
http://www.claritycon.com/


Quote:
> I have a type library created in C++ (.tlb).  this library has been loaded
> into my project as a reference many times with no problems.  now, it
simply
> won't work.  i get an error "unable to load type library".  what can cause
> this?  why did it work for so long and suddenly it is giving me a hard
time?

> jeff



Sat, 23 Apr 2005 04:46:50 GMT  
 type library
i changed the output name.  i went back and changed the name back to what it
was and it appears to work now.  the name had "-"'s and spaces in it, but
the original name did not.  likely an ms bug?

jeff



Quote:
> j h, what changed about the tlb?  Did you recompile it?  Did you change
it's
> location?  Try running tlbimp on it again or deleting it and readding it
to
> your project references.

> --
> Greg Ewing [MVP]
> http://www.claritycon.com/



> > I have a type library created in C++ (.tlb).  this library has been
loaded
> > into my project as a reference many times with no problems.  now, it
> simply
> > won't work.  i get an error "unable to load type library".  what can
cause
> > this?  why did it work for so long and suddenly it is giving me a hard
> time?

> > jeff



Sat, 23 Apr 2005 21:28:37 GMT  
 
 [ 5 post ] 

 Relevant Pages 

1. MessengerAPI type library - IDispatch enum type problem

2. HRESULT return type turns into void when adding class from type library

3. Exposing interfaces in a type library that are infact defined in another type library.

4. Type Library problem

5. How to get the type-library GUID in an attributed ATL project

6. Registering C# type library in COM+ fails

7. Newbie Question about type libraries

8. regex type libraries for C?

9. Type Library 1.0

10. NEEDED: DOS C-compiler with GKS type library

11. Making a type library

12. How to include a type library as a resource in an exe

 

 
Powered by phpBB® Forum Software