Debugger does not show time of DateTime variable 
Author Message
 Debugger does not show time of DateTime variable

I must be doing something really dumb using Visual C# .NET. If I set a
breakpoint on the MessageBox.Show call in the following code and
examine the value of fileDateTime in the Autox window or by placing
the cursor over the variable name I see {12/9/2002} with no time.
However, the MessageBox shows both the date and time.

How can I get the de{*filter*} to show both the date and time parts of a
DateTime value?

string dateTimeString = dateTextBox.Text + " " + timeTextBox.Text;
DateTime fileDateTime = DateTime.Parse(dateTimeString);
MessageBox.Show(fileDateTime.ToString());

Bill

--
Bill



Sat, 28 May 2005 04:04:54 GMT  
 Debugger does not show time of DateTime variable
Bill,

Quote:
>How can I get the de{*filter*} to show both the date and time parts of a
>DateTime value?

Change the entry for System.DateTime in your
VS.NET\Common7\Packages\De{*filter*}\mcee_cs.dat file.

Mattias

===

http://www.*-*-*.com/
Please reply only to the newsgroup.



Sat, 28 May 2005 04:40:14 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. static variables not showing up in debugger

2. Debugger shows incorrect global static variable structure

3. Debugger shows function calls overwriting other variables data!

4. wstring will not show up in debugger

5. Debugger does not show correct values

6. Debugger does not show correct values

7. UserControl does not show on running form and properies do not show

8. local static variables not able to be displayed by debugger under Windows XP

9. Variable not seen by debugger

10. IPropertyPage::Show() is not calling for second time

11. Show() is not calling for second time, when i switch from other Prop Page

12. Variable data not showing in watch windows

 

 
Powered by phpBB® Forum Software