Top Left Icon - Why Isn't it Showing Up Correctly 
Author Message
 Top Left Icon - Why Isn't it Showing Up Correctly

For Windows .EXE-type projects:

After setting the default application icon property and a form's icon
property, the icon in the top left changes from the default icon to
something looking like a little window rather than what I specify. In the
task bar, when I alt-tab to the application, the icon shows up correctly. It
also shows up correctly in Explorer.

I'm confused as to why I'm not getting the correct icon showing up.

TIA,

Randy



Mon, 21 Mar 2005 21:54:29 GMT  
 Top Left Icon - Why Isn't it Showing Up Correctly

Quote:
> For Windows .EXE-type projects:

> After setting the default application icon property and a form's icon
> property, the icon in the top left changes from the default icon to
> something looking like a little window rather than what I specify. In the
> task bar, when I alt-tab to the application, the icon shows up correctly. It
> also shows up correctly in Explorer.

> I'm confused as to why I'm not getting the correct icon showing up.

Is it the case that one particular icon size works and the other
doesn't? If so, look at the different images in your icon file - one of
them may still be a default one.

--

http://www.pobox.com/~skeet/
If replying to the group, please do not mail me too



Mon, 21 Mar 2005 22:20:40 GMT  
 Top Left Icon - Why Isn't it Showing Up Correctly

Quote:

> > For Windows .EXE-type projects:

> > After setting the default application icon property and a form's icon
> > property, the icon in the top left changes from the default icon to
> > something looking like a little window rather than what I specify. In
the
> > task bar, when I alt-tab to the application, the icon shows up
correctly. It
> > also shows up correctly in Explorer.

> > I'm confused as to why I'm not getting the correct icon showing up.

> Is it the case that one particular icon size works and the other
> doesn't? If so, look at the different images in your icon file - one of
> them may still be a default one.

Wow, now that was intuitive. I had what I thought was only a 32x32 icon. Had
to right click in the icon painter preview window to show the other icon
types. The default 16x16 was messing me up.

Thanks Jon!!! Much appreciations for the help.



Mon, 21 Mar 2005 23:57:09 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Why my icons dosen't show????

2. Loop logic isn't working correctly

3. typeof isn't enough to define swap correctly

4. Little icon in the top left corner

5. App icon not showing correctly

6. Q: ScrollWindow doesn't repaint correctly under top level windows

7. NULL isn't 0/0 isn't NULL

8. Combo box isn't show any text ?

9. ListView items don't show correctly

10. Icon doesn't display correctly in system tray

11. Desktop icon isn't right

12. why isn't stdio full-duplex?

 

 
Powered by phpBB® Forum Software