Problem Debugging Threads in a Windows Service Application 
Author Message
 Problem Debugging Threads in a Windows Service Application

I am working with a Windows Service Application that has many threads.  When
I attach the de{*filter*} to the running service process I don't get any threads
in the threads window, and all of the other de{*filter*} windows appear empty
but the de{*filter*} is definatly attached to the process.  Any hints?

- Will Baldwin



Sun, 04 Jul 2004 11:40:53 GMT  
 Problem Debugging Threads in a Windows Service Application
I had a similar problem; I was hoping I could watch the thread execution as
the prgram runs.  The threads wont appear in the window until you pause your
programs execution.  (Either use a break proint or hit ctrl-break).

- Chris

Quote:
> I am working with a Windows Service Application that has many threads.
When
> I attach the de{*filter*} to the running service process I don't get any
threads
> in the threads window, and all of the other de{*filter*} windows appear empty
> but the de{*filter*} is definatly attached to the process.  Any hints?

> - Will Baldwin



Sun, 04 Jul 2004 11:58:19 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. How to Debug Windows Service Application

2. Get application path from Windows Service Application

3. CWebBrowser thread debug results (Windows 95 vs Windows NT)

4. Awakening the UI thread from another thread in a Windows Form application

5. problem: debugging a service while logged in via terminal services client

6. how to debug the service application(win2000)

7. Windows Service debugging question

8. Debugging a windows service

9. Threading in a Windows Service

10. How to debug windows nt services

11. debugging Windows Service

12. Debugging a Service Program in Windows 2000

 

 
Powered by phpBB® Forum Software