ext/tcltklib/demo/lines1.rb failed 
Author Message
 ext/tcltklib/demo/lines1.rb failed

ruby-1.6.1 (Sept.22 2000 cvs snapshot source)
solaris2.7 (sparc)
gcc-2.9.1

/usr/local/lib/ruby/1.6/tkfont.rb:993: infinite load loop -- tkfont.rb (LoadError)
        from /usr/local/lib/ruby/1.6/tkcanvas.rb:9:in `require'
        from /usr/local/lib/ruby/1.6/tkcanvas.rb:9
        from /home/wang/lines1.rb:40

does anyone has any idea?



Tue, 11 Mar 2003 03:00:00 GMT  
 ext/tcltklib/demo/lines1.rb failed
Hi,

In message "[ruby-talk:5065] ext/tcltklib/demo/lines1.rb failed"

|ruby-1.6.1 (Sept.22 2000 cvs snapshot source)
|solaris2.7 (sparc)
|gcc-2.9.1
|
|/usr/local/lib/ruby/1.6/tkfont.rb:993: infinite load loop -- tkfont.rb (LoadError)
|        from /usr/local/lib/ruby/1.6/tkcanvas.rb:9:in `require'
|        from /usr/local/lib/ruby/1.6/tkcanvas.rb:9
|        from /home/wang/lines1.rb:40
|
|does anyone has any idea?

I have.  It's a bug.  I recently added load loop check, but forgot to
handle autoloading, which tk library uses.  Try the latest CVS, or
tomorrow's snapshot.

                                                        matz.



Wed, 12 Mar 2003 02:14:49 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. problem with compilation of ext/tcltklib

2. install.rb and extensions in /ext

3. From Demo to Full RB 5.1

4. RB for windows demo bug?

5. RB 452 DEMO and MySQL

6. cgi.rb:490:in `+': failed to convert Fixnum into String

7. Demo/extend fails in 2.2

8. Demo/embed fails on two UNIX platforms in Python 1.4

9. Execution of the BWidgets demo fails

10. first demo program fails

11. any tk demo app fails

12. running ./library/demos fails for tk3.0

 

 
Powered by phpBB® Forum Software