eruby and mod_ruby on Mac OS X 
Author Message
 eruby and mod_ruby on Mac OS X

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,

did anybody succeed in running eruby and mod_ruby with Apache/1.3.23 on Mac OS X.

All three, ruby, eruby and mod_ruby compiled fine except that mod_ruby compilation quits at first, claiming that libruby.a would be outdated and ranlib should be run again. After doing this even mod_ruby compiles fine.

However, httpd.conf is properly configured but the error_log states that eruby cannot be loaded. This happens with the current versions (ruby 1.6.7, eruby 0.9.8 and mod_ruby 0.9.8) as well as with older versions (ruby 1.6.6, eruby 0.9.7 and mod_ruby 0.9.4)

Can anybody tell me what I possibly could do to use embedded ruby on my Mac Webserver?

Thank you very much.

Servus

Alexander

- --
Alexander Nouak
zeitform Internet Dienste       Rundeturmstrasse 6
                                64283 Darmstadt, Germany
http://www.*-*-*.com/          Tel: +49 (0)6151 155-637

GnuPG/PGP Key-ID: 0xD042D3EB

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.0.7 (Darwin)

iD8DBQE87gOn0HWns9BC0+sRAoc4AKDTRfAGk2NwI+Cma9UfCgHZavWVWgCfc5tU
fcWOLgdTzZJZpA5X7Y9Xf2I=
=Ra9l
-----END PGP SIGNATURE-----



Tue, 09 Nov 2004 17:11:34 GMT  
 eruby and mod_ruby on Mac OS X

Quote:
> did anybody succeed in running eruby and mod_ruby with Apache/1.3.23
> on Mac OS X.

Compiling, yes.  Running, no.  I spent an hour or so trying to get
this to work on Jack Herrington's OS-X laptop before the ba-rb meeting
last Sunday but didn't have any success in getting it to actually
work.  If anyone has an OS-X laptop that they'd be willing to let me
have access to for a few hours, I'd like to see if I can get mod_ruby
to work on OS-X.  -sc

Quote:
> All three, ruby, eruby and mod_ruby compiled fine except that
> mod_ruby compilation quits at first, claiming that libruby.a would
> be outdated and ranlib should be run again. After doing this even
> mod_ruby compiles fine.

> However, httpd.conf is properly configured but the error_log states
> that eruby cannot be loaded. This happens with the current versions
> (ruby 1.6.7, eruby 0.9.8 and mod_ruby 0.9.8) as well as with older
> versions (ruby 1.6.6, eruby 0.9.7 and mod_ruby 0.9.4)

> Can anybody tell me what I possibly could do to use embedded ruby on
> my Mac Webserver?

> Thank you very much.

--
Sean Chittenden


Tue, 16 Nov 2004 05:15:12 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. mod_ruby, eruby on Mac OS X 10.2

2. mod_ruby and Mac OS X

3. mac os x eruby

4. eRuby on Mac OS X

5. Web Hosts That Support mod_ruby and eRuby?

6. eRuby/mod_ruby hosting proposal

7. mod_ruby / eruby: intermittent failure to load file

8. cookies in eruby mod_ruby

9. Ruby, mod_ruby, eruby

10. getting eRuby to run under mod_ruby

11. Is there any mod_ruby/eruby for Windoze XP?

12. mod_ruby - eruby - apache 2?

 

 
Powered by phpBB® Forum Software