RELEASED: Pymacs 0.16 
Author Message
 RELEASED: Pymacs 0.16

Hi!  A new release of Pymacs is available as:

    http://www.*-*-*.com/ ~pinard/pymacs/Pymacs.tar.gz

(Beware: the capital `P' was a lower case `p' in previous announcements.)

Pymacs allows Emacs users to extend Emacs using Python, where they might have
traditionally used Emacs LISP.  Pymacs runs on systems having sub-processes.

No bugs were reported against the Pymacs proper.  So, I got to risk some
new ones :-).  There is no real need to upgrade, but testers are welcome.

As previously announced, Pymacs is now to be invoked by:

    from Pymacs import lisp, Let

instead of:

    import pymacs
    from pymacs import lisp
    Let = pymacs.Let

The goal is to turn Pymacs into a more genuine python package, in the spirit
of Distutils.  A tiny module gets installed so the previous methods work, be
warned that this compatibility module will disappear in some later release.

The various `push' methods of the `Let' class now return the `Let' instance
they act upon.  This eases chaining pushes while creating such an instance.

Finally, the `rebox.py' example had two bugs corrected, one about unusual
argument flags, the other for older versions of Python.

                                    Keep happy!  Enjoy, enjoy! :-)

--
Fran?ois Pinard   http://www.*-*-*.com/ ~pinard



Sun, 18 Jul 2004 09:01:49 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. RELEASED: Pymacs 0.16

2. Glasgow Haskell 0.16 documents in PostScript available

3. Glasgow Haskell compiler, version 0.16, available [REPOST]

4. MacGofer 0.16 (Beta) Available for FTP

5. Lisp Interpreted (fib 20) now in 0.16 seconds

6. xscheme: has anybody a more recent version than 0.16

7. Problem with XScheme 0.16

8. Avalability of XScheme(V 0.16) and XLisp(V 2.0)

9. RELEASED: Pymacs 0.21

10. RELEASED: Pymacs 0.20

11. RELEASED: Pymacs 0.19

12. RELEASED: Pymacs 0.18

 

 
Powered by phpBB® Forum Software