;;; LIB messages 
Author Message
 ;;; LIB messages

Hullo again,
        Well it's good to see that posting here gets results...
So far I have received the following, unfortunately none of them solve my
problem :-)


Use "uses" instead of "lib"?

This is OK if the library you are loading doesn't then load further
libraries. The flavours library unfortunately loads several other libraries
itself.


Try calling the procedure loadlib("libraryname")

Same problem as above.


Poplog 14.2 introduced a variable "libwarning" for this purpose.
It is documented in REF LIBRARY (but not, unfortunately, in HELP LIB).

This is what I am looking for, unfortunately we use V14.1 (infact I use
V14.1, no one else uses POPLOG at all and Sys Admin keep trying to get
rid of it, particularly as they are having to keep some X11R4 stuff around
especially for me, when everyone else is on R5 :-)

Two ideas I have are either to modify the flavours library to use uses or
loadlib, or to temporarily redirect the messages to the POP equivilent of
/dev/nul. Comments please...?

Thanks.

Daniel.



Sun, 26 Nov 1995 18:53:36 GMT  
 ;;; LIB messages

Quote:
> This is OK if the library you are loading doesn't then load further
> libraries. The flavours library unfortunately loads several other libraries
> itself.

This strikes me as a bug in the Flavours libraries which should be
reported (see HELP BUGFORM) and which should be fixed.

In the mean time, look at the LIB LIB library and redefine it before
you load any libraries.

Aaron



Sun, 26 Nov 1995 21:38:53 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Suppressing ;;;LIB messages

2. Suppressing ;;;LIB messages

3. re-defining lib to suppress messages.

4. Linking sqldedev.lib, desktopenginedeploy.lib to my app: unsupported recordtype 21

5. S87 - Libraries (NL187.LIB & NLEXT87.LIB)

6. sup3552.lib & classy.lib

7. funcky.lib - overcl.lib

8. Need Clipon.lib and Super35.lib

9. Need old lib file - expand.lib

10. I'm looking for two libraries: mlibca.lib, ct.lib

11. PCFUNC.LIB AND PCKERNEL.LIB

12. BLXRATEX.LIB and BLXCLP53.LIB for BLINKER V4.1

 

 
Powered by phpBB® Forum Software