looping problems on PL/1 AIX. 
Author Message
 looping problems on PL/1 AIX.

All,
  we've recently switched to using PL/1 from MVS Mainframe to an IBM AIX
box. However a handful of our programs which use large quantities of
Allocated storage have a tendency to loop. One program I've been dealing
looped on the statement which was dynamically allocating a six dimensional
array. Whist the array was huge (some 1 million elements- and each element
being 48 bytes large) I am obviously frustrated that the code seemingly
loops for no real reason. The program works perfectly on the mainframe (if
we connect to the AIX to carry out all the DB2). First of all has anyone
else come across this problem (does anyone use PL/1 on AIX??) and if not can
anyone point me in the direction of  a possible site that has logged
problems with PL/1 compilers.

Lastly can someone point me to a (readable) source for the many PL/1
compiler options.

Thankyou

Paul.



Sat, 10 Aug 2002 03:00:00 GMT  
 looping problems on PL/1 AIX.

Quote:
>   we've recently switched to using PL/1 from MVS Mainframe to an IBM AIX
> box. However a handful of our programs which use large quantities of
> Allocated storage have a tendency to loop.

Do you need to specify a stack size?
Quote:
> Thankyou

> Paul.



Sun, 11 Aug 2002 03:00:00 GMT  
 looping problems on PL/1 AIX.
There was a bug of this sort a very long time ago, but has been resolved for
quite some time (on the order of years).
Perhaps you need to check your maintenance level? Otherwise, get your AIX
team to open a PMR - your compiler is supported and very few AIX sites do
not have service agreements.

Compiler options are in the Programming Guide, which is supplied on-line on
AIX, but in "INF" format (yes, really!). An INF viewer is also supplied. I
have always accessed this through the CDE icons. I am not an AIX systems
engineer, so if you can't find the on-line docs, you'll have to ask your AIX
support team for help.

--
Regards, Mark Yudkin, Yudkin Consulting AG, Authors of Cogent/SQL for MVS,
OS/2 and Windows NT.
The simplest way to publish live data on the World Wide Web.


Quote:
> All,
>   we've recently switched to using PL/1 from MVS Mainframe to an IBM AIX
> box. However a handful of our programs which use large quantities of
> Allocated storage have a tendency to loop. One program I've been dealing
> looped on the statement which was dynamically allocating a six dimensional
> array. Whist the array was huge (some 1 million elements- and each element
> being 48 bytes large) I am obviously frustrated that the code seemingly
> loops for no real reason. The program works perfectly on the mainframe (if
> we connect to the AIX to carry out all the DB2). First of all has anyone
> else come across this problem (does anyone use PL/1 on AIX??) and if not
can
> anyone point me in the direction of  a possible site that has logged
> problems with PL/1 compilers.

> Lastly can someone point me to a (readable) source for the many PL/1
> compiler options.

> Thankyou

> Paul.



Tue, 13 Aug 2002 03:00:00 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. AIX porting problem - cannot build libtcl8.3.so - Linux AIX Toolkit

2. Problem with Tcl 8.0 load on AIX 3.2.5, AIX 4.1

3. PL/I Set for AIX

4. Pl/1 for Aix

5. PL/1 for AIX(RISC)

6. Problem with loop inside other loop

7. Need help with executables compiled on AIX 4.3 but being run on AIX 3.2

8. Fortran Executable from AIX 3.1.2 used under AIX 4.1

9. tcl 8.0 load test fails on AIX 4.1.x and AIX 4.2.1

10. Python 2.2.2 on AIX 4.3.3 / AIX 5.1

11. I/O Problem AIX XL Fortran IBM - HELP !

12. cvs access problems on AIX

 

 
Powered by phpBB® Forum Software