This is making me crazy...(getOpenFile) 
Author Message
 This is making me crazy...(getOpenFile)

Hi,

GetOpenFile is bugging me...

I am running MacOSX 10.2.1 perl 5.8 and perl/tk 800.024.

The getOpenFile call has "stopped working" for me, ie it always returns
A null filename.

Here is a minimal example...

#!/usr/local/bin/perl
use Tk;

$mw = new MainWindow;

 my $myfile;
 my $types;

# Get the CSV file name

 $myfile = $mw->getOpenFile(-title=>"FooBar");
 print "...$myfile...\n";

MainLoop;

The print statement above *always*  prints "......" ie there is nothing in
$myfile.

I have tried many variations of parameters but I always get the same result,
Nothing!

The weird thing is that in the distribution "widget" demo there is a
getOpenFile "test" that works!

What in the world can be the problem?

--Jerry



Sat, 26 Mar 2005 01:37:51 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Search results problem is making me crazy

2. Crazy print statement problem

3. feel like i'm going crazy...

4. Help with this Crazy script!

5. I'm going crazy

6. E-mailing with perl is driving me crazy!

7. DBI is driving me crazy!

8. Crazy RegExp please?

9. Crazy Math

10. Crazy Idea

11. Dealing with #!/crazy/location/perl

12. This is driving me crazy!!

 

 
Powered by phpBB® Forum Software