symbol not found: gettimeofday in SVR4 Motorola (Tk402.001 w/perl 5.004_01) 
Author Message
 symbol not found: gettimeofday in SVR4 Motorola (Tk402.001 w/perl 5.004_01)

Hi all,

Well, after trying to compile Tk402.000 for almost a week I gave up
and waited for the new release. I got perl 5.004_01 compiled no
problem, all tests passed.

Then I got Tk402.001 and everything in the configuration and
compilation went excellent, no warnings nothing, excellent work!!!!

But, when I tried to do make test I get:


        cd pTk && make
        /bin/cc -c  -I/usr/include -I/usr/local/include -O
-DVERSION=\"402.001\"  -DXS_VERSION=\"402.001\" -KPIC
-I/usr/local/pkg/perl/5.004/lib/m88k-svr4/5.00401/CORE -DBASEEXT=\"Tk\"  tkGlue.c
        LD_RUN_PATH="/usr/lib:/usr/ccs/lib" /bin/cc -o
./blib/arch/auto/Tk/Tk.so  -G -L/usr/ccs/lib
-L/usr/local/lib Tk.o  leak_util.o  tixGlue.o  tkGlue.o  tkGlue_f.o  winMain.o  pTk/libpTk.a  -L/usr/lib -lX11 -lsocket -lnsl -lm
        chmod 755 ./blib/arch/auto/Tk/Tk.so
        /usr/local/pkg/perl/5.004/bin/perl -I./blib/arch -I./blib/lib demos/widget
dynamic linker: /usr/local/pkg/perl/5.004/bin/perl: symbol not found: gettimeofday
*** Termination code 9 (bu21)
current working directory is: = /tmp_mnt/usr/local/pkg/pTk/Tk402.001/bld

make: fatal error.

Now, when at the very beggining I see this:


/usr/local/pkg/perl/5.004/bin/perl is installed in /usr/local/pkg/perl/5.004/lib/m88k-svr4/5.00401 okay
Test Compiling config/signedchar.c
Test Compiling config/Ksprintf.c
Test Compiling config/tod.c
Test Compiling -DTIMEOFDAY_TZ config/tod.c
Test Compiling -DTIMEOFDAY_NO_TZ config/tod.c
NO_TZ gettimeofday()
/usr/bin/X11/xmkmf suggests /usr
Using -L/usr/lib to find /usr/lib/libX11.so.5.0
Using -I/usr/include to find /usr/include/X11/Xlib.h
Note (probably harmless): No library found for -lpt
Writing Makefile for Tk::Bitmap

So it seems it went trhough the phase of configuring gettimeofday but
still something went wrong.  I am so close to getting this to work....

can anyone please give me any directions as to what I can try to fix
to get this to work?

My uname -a gives:

UNIX_System_V nav1 4.0 R40V4.3 m88k mc88100

With perl -V giving:


Summary of my perl5 (5.0 patchlevel 4 subversion 1) configuration:
  Platform:
    osname=svr4, osvers=, archname=m88k-svr4
    uname='unix_system_v nav1 4.0 r40v4.3 m88k mc88100 '
    hint=recommended, useposix=true, d_sigaction=define
    bincompat3=y useperlio= d_sfio=
  Compiler:
    cc='/bin/cc', optimize='-O', gccversion=2.4.5
    cppflags='-I/usr/include -I/usr/local/include'
    ccflags ='-I/usr/include -I/usr/local/include'
    stdchar='unsigned char', d_stdstdio=define, usevfork=false
    voidflags=15, castflags=0, d_casti32=define, d_castneg=define
    intsize=4, alignbytes=8, usemymalloc=y, randbits=15
  Linker and Libraries:
    ld='/bin/cc', ldflags ='-L/usr/ccs/lib -L/usr/local/lib'
    libpth=/usr/local/lib /shlib /lib /usr/lib /usr/ccs/lib
    libs=-lsocket -lnsl -ldl -lld -lm -lc
    libc=/shlib/libc.so.1, so=so
    useshrplib=true, libperl=libperl.so.401
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=, ccdlflags=' '
    cccdlflags='-KPIC', lddlflags='-G -L/usr/ccs/lib -L/usr/local/lib'

Characteristics of this binary (from libperl):
  Built under svr4
  Compiled at Jun 20 1997 13:13:31

    /usr/local/pkg/perl/5.004/lib/m88k-svr4/5.00401
    /usr/local/pkg/perl/5.004/lib
    /usr/local/pkg/perl/5.004/lib/site_perl/m88k-svr4
    /usr/local/pkg/perl/5.004/lib/site_perl
    .

Looking forward to getting a possible solution,
--

Nortel Montreal - #include <std_disclaimer.h>



Tue, 07 Dec 1999 03:00:00 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Solaris DB_File.so: symbol dbopen: referenced symbol not found

2. Installing perl on Motorola SVR4

3. Tk402.001 and Irix 5.3

4. Test error from Tk402.001

5. Tk402.001 fails to build under FreeBSD 2.2-STABLE

6. Tk402.001: stdio.h problem and workaround

7. Tk-b9.01 for Motorola SVR4 compile patches

8. Can't build Tk402.001 - gettimeofday unresolved symbold - HELP!

9. Perl XS - symbol not found

10. Problem with tkperl on Solaris 2.3 - symbol not found: __floatdid

11. Getting error of perl_get_sv : symbol not found from dynamic linker

12. relocation error: symbol not found: _fpgetround occurs when making test for GD.pm

 

 
Powered by phpBB® Forum Software