module installation problem...... 
Author Message
 module installation problem......

Hi:
     I am a newbie of Perl and Linux.I am using Red Hat 5.2. I tried to
install the Tk800.010.tar.gz from the CD that comes with the book "Perl
power".
I copied the module into /usr/lib/perl5 and type the following commands:

               gzip -d Tk800.010.tar.gz
               tar xfv Tk800.010.tar
               cd Tk800.010
               perl Makefile.PL
               make
               make test
               make install

 Everything goes fine. But when I tried to compile a simple program by
inserting"use Tk" in it,the compiler complains saying" Goto undefined
subroutine &main::-1 at /usr/lib/perl5/Tk/Widget.pm line 318".

  Could anybody help me regarding this issue?
  (My Perl is version 5.004_04)

      Thanx



Mon, 19 Aug 2002 03:00:00 GMT  
 module installation problem......

Quote:

> Hi:
>      I am a newbie of Perl and Linux.I am using Red Hat 5.2. I tried to
> install the Tk800.010.tar.gz from the CD that comes with the book "Perl
> power".
> I copied the module into /usr/lib/perl5 and type the following commands:
>                gzip -d Tk800.010.tar.gz
>                tar xfv Tk800.010.tar
>                cd Tk800.010
>                perl Makefile.PL
>                make
>                make test
>                make install
>  Everything goes fine. But when I tried to compile a simple program by
> inserting"use Tk" in it,the compiler complains saying" Goto undefined
> subroutine &main::-1 at /usr/lib/perl5/Tk/Widget.pm line 318".
>   Could anybody help me regarding this issue?
>   (My Perl is version 5.004_04)
>       Thanx

The perl bundled with that RH is defective.  Install a new/fixed perl rpm
and re-install Tk.  BTW, Tk 800.015 is recommended over .010.

--
--

Lehigh University Computing Center, USA



Mon, 19 Aug 2002 03:00:00 GMT  
 module installation problem......

Quote:

> The perl bundled with that RH is defective.  Install a new/fixed perl rpm
> and re-install Tk.  BTW, Tk 800.015 is recommended over .010.

You can also install the perl version that comes with the book. It's been
tested to work fine with the Tk on the same CD. If you prefer to go with the
newest stable releases, you can download them from www.perl.com and CPAN
(it's about 7 MB total). Appendix A in the book walks you through the steps
involved. If you have any questions, don't hesitate to write me an email,
I'll help you out.

-- Michael
----------------------------------------------------
Michael Schilli               http://perlmeister.com
----------------------------------------------------



Thu, 22 Aug 2002 03:00:00 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. MD5 module installation problems

2. Data-Dumper module installation problems

3. Module installation problem

4. module installation problem

5. Data-Dumper module installation problems

6. gdchart perl module installation problem

7. Msql module installation problems.

8. ActivePerl Modules Installation Problems

9. Win 98 and Modules Installation problems Make??

10. Data-Dumper module installation problems

11. MD5 module installation problems

12. module installation problem

 

 
Powered by phpBB® Forum Software