Problems in perl versions while tring to install pTk 
Author Message
 Problems in perl versions while tring to install pTk

Hi,

I am trying to install Ptk on our site from the file  'Tk402.001.tar'
that i was downloaded from the latest Tk release in the
'modules/by-authors/Nick_Ing-Simmons/' directory at any CPAN ftp site.
After passing the 'make' stage, while executing the command 'make test'
I have got the following error message:
 /usr/local/bin/perl5 -I./blib/arch -I./blib/lib demos/widget
Perl 5.00397 required--this is only version 5.003, stopped at
blib/lib/Tk.pm line 11.
BEGIN failed--compilation aborted at demos/widget line 26.

Can you help me with the steps I need to do in order to enhance our
perl5 version from 5.003 to 5.00397 ????

--  

--- Boaz Carmely
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;;; R&D Engineer               ;;  ORNET Data Communication Technologies
Ltd.

;;; phone: +972-4-9981314      ;;  Karmiel 21613, Israel.
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
==========================================================================
This message was posted through the Stanford campus mailing list
server.  If you wish to unsubscribe from this mailing list, send the

--




Mon, 20 Dec 1999 03:00:00 GMT  
 Problems in perl versions while tring to install pTk

 > Hi,
 >
 > I am trying to install Ptk on our site from the file  'Tk402.001.tar'
 > that i was downloaded from the latest Tk release in the
 > 'modules/by-authors/Nick_Ing-Simmons/' directory at any CPAN ftp site.
 > After passing the 'make' stage, while executing the command 'make test'
 > I have got the following error message:
 >  /usr/local/bin/perl5 -I./blib/arch -I./blib/lib demos/widget
 > Perl 5.00397 required--this is only version 5.003, stopped at
 > blib/lib/Tk.pm line 11.
 > BEGIN failed--compilation aborted at demos/widget line 26.
 >
 > Can you help me with the steps I need to do in order to enhance our
 > perl5 version from 5.003 to 5.00397 ????

Read the error message as "Perl5.003_97 or higher required--...". So
grab 5.004_01 on CPAN (src/latest.tar.gz or src/5.0/perl5.004_01.tar.gz)

The INSTALL file in the distribution explains how to install/upgrade perl.

Achim
P.S. Nick: How about a 'require 5.00397;' or even 5.004(_01)? in the
     Makefile.PL and a comment about perl version in README?

==========================================================================
This message was posted through the Stanford campus mailing list
server.  If you wish to unsubscribe from this mailing list, send the

--




Mon, 20 Dec 1999 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. pTk Install Problems

2. Problem with two versions of Perl installed

3. After install of perl5.003, now can't install pTk

4. ptk vs pTk vs PTK

5. How to Install pTk-b9.01 + japanization patch on Perl 5.003

6. How to Install pTk-b9.01 + japanization patch on Perl 5.003

7. HELP: Install pTk NOT in the perl-tree

8. Newbie: Problem installing private version of HTML::Parse

9. Pat space doesn't change in nested whiles

10. Ptk win32 and unix versions

11. Binary version pf ptk for WinNT?

12. tring to get undump to work

 

 
Powered by phpBB® Forum Software