Need help with IOCTL on HP-UX 
Author Message
 Need help with IOCTL on HP-UX

I have installed perl5.6.1.
I have compiled it myself  and have installed on that HP has
distributed. In both cases I have the same problem with IOCTL.  I  get
"invalid argument" when I try the IOCTL command.  The "invalid
arguement" is in the contents of "$!" , IOCTL returns NULL.

I have run the "h2ph -r -l *" from /usr/include.

I have tried the code below and the samlpe code that I found with the
perldocs on ioctl.  Same result as above.

Any  Suggestions?
Thanks,
--Keith

Here is a sample of the test code:
==========================================================================
#!/usr/local/bin/perl

use POSIX;
use IO::Handle;

require 'sys/modem.ph';
require 'termios.ph';
require 'sys/termios.ph';
require 'sys/termiox.ph';
require 'sys/ttold.ph';
require 'sys/strtio.ph';

my $junk;

my $rc = 0;

my $fd = POSIX::open("/dev/tty2a7",&POSIX::O_RDWR | &POSIX::O_NOCTTY |
&POSIX::O_NONBLOCK ) ;

my $handle = new_from_fd IO::Handle ($fd, "r");
$tcgetx = defined(&TCGETX) ? &TCGETX :0;
print "\n\nTCGETX=>>$tcgetx<<\n\n";

$rc = ioctl($handle,$tcgetx, $junk);

print "\nIOCTL RC=>>$rc<<\nSYSTEM returned >>$!<<\n\n\n";

POSIX::close($fd);
==========================================================================



Tue, 13 Apr 2004 20:43:13 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. format fdd

2. Glide Routines (3DFX API)

3. Master-Detail on Expression index

4. perl 4.036 vs. HP-UX 9.0 (help needed)

5. perl on HP-UX 8.0 (9000/800) (help needed)

6. Help needed compiling DB_File on HP-UX 11

7. I need help w/ C++ XS and HP-UX

8. I need help w/ C++ XS and HP-UX

9. Need Help Compiling Perl 5.004_04 on HP-UX 9

10. Need help compiling perl5 on HP-UX

11. **** PERL SYBASE ODE HP-UX PROGRAMMERS NEEDED ****

12. I need the TK module for HP/UX 10

 

 
Powered by phpBB® Forum Software